summaryrefslogtreecommitdiff
path: root/app-backup/attic/attic-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-backup/attic/attic-9999.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-backup/attic/attic-9999.ebuild')
-rw-r--r--app-backup/attic/attic-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-backup/attic/attic-9999.ebuild b/app-backup/attic/attic-9999.ebuild
new file mode 100644
index 000000000000..faaffb46778a
--- /dev/null
+++ b/app-backup/attic/attic-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=( python3_{4,5} )
+
+inherit distutils-r1
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jborg/attic.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jborg/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Attic is a deduplicating backup program written in Python."
+HOMEPAGE="https://attic-backup.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="libressl"
+
+RDEPEND="
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ dev-python/llfuse[${PYTHON_USEDEP}]"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/cython[${PYTHON_USEDEP}]
+ ${RDEPEND}"