summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-13 12:04:20 +0100
commitd993571e2ee444d08f4e9e90d493ee37338657e3 (patch)
tree5a49a1d4ceffe800051e363f64571c3b6735d2f7 /app-arch
parent266d65d0cceeb55ab2cc3bf4e465d7f35502a900 (diff)
gentoo auto-resync : 13:04:2024 - 12:04:19
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/7zip/7zip-23.01.ebuild16
-rw-r--r--app-arch/7zip/Manifest4
-rw-r--r--app-arch/7zip/files/7zip-23.01-respect-build-env.patch4
-rw-r--r--app-arch/Manifest.gzbin18264 -> 18261 bytes
4 files changed, 12 insertions, 12 deletions
diff --git a/app-arch/7zip/7zip-23.01.ebuild b/app-arch/7zip/7zip-23.01.ebuild
index 631aad045b4c..cd0af0601e23 100644
--- a/app-arch/7zip/7zip-23.01.ebuild
+++ b/app-arch/7zip/7zip-23.01.ebuild
@@ -8,12 +8,12 @@ inherit edos2unix flag-o-matic toolchain-funcs
NO_DOT_PV=$(ver_rs 1- '')
DESCRIPTION="Free file archiver for extremely high compression"
HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
-# linux-x64 tarball is used for docs
+# linux-x64 tarball is only used for docs
SRC_URI="
mirror://sourceforge/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
mirror://sourceforge/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
"
-S="${WORKDIR}/CPP/7zip"
+S="${WORKDIR}"
LICENSE="LGPL-2 BSD rar? ( unRAR )"
SLOT="0"
@@ -63,16 +63,18 @@ pkg_setup() {
src_prepare() {
# patch doesn't deal with CRLF even if file+patch match
# not even with --ignore-whitespace, --binary or --force
+ pushd "./CPP/7zip" || die "Unable to switch directory"
edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
+ sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
+ popd >/dev/null || die "Unable to switch directory"
default
-
- sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
}
src_compile() {
- pushd "./Bundles/Alone2" || die "Unable to switch directory"
+ pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
+ # avoid executable stack when using uasm/jwasm, harmless otherwise
append-ldflags -Wl,-z,noexecstack
export G_CFLAGS=${CFLAGS}
export G_CXXFLAGS=${CXXFLAGS}
@@ -102,8 +104,6 @@ src_compile() {
}
src_install() {
- dobin "./Bundles/Alone2/b/${bdir}/7zz"
-
- pushd "${WORKDIR}" || die "Unable to switch directory"
+ dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
einstalldocs
}
diff --git a/app-arch/7zip/Manifest b/app-arch/7zip/Manifest
index fc601182eb0d..419bbac8b025 100644
--- a/app-arch/7zip/Manifest
+++ b/app-arch/7zip/Manifest
@@ -1,5 +1,5 @@
-AUX 7zip-23.01-respect-build-env.patch 1538 BLAKE2B 59d6b0629943ad97df334b377f0df00ce746a43a3263f971b21c8ffa7813dc3dd3ae3adbada8e3459f1ae1bad24fafbdace7bbb1a123e5851e32876143b0e035 SHA512 1f83812d0c86cb586a6fdb4738e117a4fd6d6ba9a8e3ffdaa83620a8b81fa186216478ab7e4c119e5d3f43faa940acde8e4f9d29ae13dc7a7c326801b8cce923
+AUX 7zip-23.01-respect-build-env.patch 1556 BLAKE2B fdc1993dbcdc1bac28420d82ae19906be1c9857b7e0822f87d8c40003c55182b42b2f6ebde17897c4e1b074fe518cd4dc8d1c09a7d96d8be599aed5d2d506c91 SHA512 52dc54e980a729291fcadd097c6291fe33183c81cc92e30b10f5ad9c3f7ae09d8b0d3fd483c766ed63fb977b71b28eec0a78b2d4c7c054f68bcb63b8ef57d69a
DIST 7z2301-linux-x64.tar.xz 1527700 BLAKE2B 35dc74f0a7a4e586ea5ae969dce72c14e0231822630d2d70f24e1c911cea0492354a258ef65096a6ce0da1510117c12466bc6cda577cdf9e8e74ede17e47f23e SHA512 d3549468de8fd161e4c9233fa0b170af1f28c74749d20f3d0eeb3873857f6c6d2cc0777d564e6a79be7cc21c9e982e10710a795320428dc51db809a8d0f9454e
DIST 7z2301-src.tar.xz 1378588 BLAKE2B 348484b24b39db70e513fe50d79954ea0e2dd669f83e3601fa796c8f0ca4734132ca20fac8cda9b8ba550bad9146627fc0ae07056abb99028ef6d825b6a533bd SHA512 e39f660c023aa65e55388be225b5591fe2a5c9138693f3c9107e2eb4ce97fafde118d3375e01ada99d29de9633f56221b5b3d640c982178884670cd84c8aa986
-EBUILD 7zip-23.01.ebuild 2728 BLAKE2B c98a594833bb404c7858bc4802a385c0aa6959968293711b743490ade7266b386a4b9ceb840d5a45a38c17683de3448341586d12fb84e86a6ec8cb9f92b96d1a SHA512 db85a2833ed052708472cd062335608368f8f6691c7287474d20d4d8e8d6ec7062055494368a558fdd35b8b76566ee85a0ada62b0827757a1b7317fc5e07eb30
+EBUILD 7zip-23.01.ebuild 2861 BLAKE2B c21a077103b4a070a5ff2076718da64612966f8c7540d65c4e10e2046a68d1dc7e26733eaaac3f10b4b0165b32711a933a2033ee826597c09301cadfb8082445 SHA512 d448b9e9f125fc0bc45718446dd9eae8aef4c4785b2df6b8390426aaa014ba635a1fbed68c47aaa6ed4c29f2e16d047b2a3b2d2ff6da2b75a98931fd63e22edb
MISC metadata.xml 967 BLAKE2B 5b54d1cc757cdc63407a51587389f9db032ae141fd9e19423185fd457f50c469ceb53095b128d8c6cd751cf3f0a87703dd36ba5d048dbfe9bea0ccd2354168b2 SHA512 c8c53c995f4bb5982461fa16dd50193f48c59aa15076bd78e38ccc4f0abf2190bf2b143df50e1c7911bd7814bd2ecb34892ee818b328764a9ff4ab2429718d37
diff --git a/app-arch/7zip/files/7zip-23.01-respect-build-env.patch b/app-arch/7zip/files/7zip-23.01-respect-build-env.patch
index c897cf625931..a5871db9159c 100644
--- a/app-arch/7zip/files/7zip-23.01-respect-build-env.patch
+++ b/app-arch/7zip/files/7zip-23.01-respect-build-env.patch
@@ -5,8 +5,8 @@ Bug: https://bugs.gentoo.org/913188
Bug: https://bugs.gentoo.org/913189
---- a/7zip_gcc.mak
-+++ b/7zip_gcc.mak
+--- a/CPP/7zip/7zip_gcc.mak
++++ b/CPP/7zip/7zip_gcc.mak
@@ -87,14 +87,14 @@ SHARED_EXT=.dll
LDFLAGS = -shared -DEF $(DEF_FILE) $(LDFLAGS_STATIC)
else
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 098b26315f83..9c452fa2e8a0 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ