summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-21 20:44:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-21 20:44:55 +0100
commitaa870ba91722a8d38ba5103297a6aa4abb54e5bc (patch)
treef91c8d19a619a57e109d68ad33c2b791a35df473 /app-arch
parent2480f36bfb3d39469cc44843d1fe664bd40443a3 (diff)
gentoo auto-resync : 21:07:2022 - 20:44:55
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin16746 -> 16911 bytes
-rw-r--r--app-arch/aptly/Manifest4
-rw-r--r--app-arch/aptly/aptly-1.5.0.ebuild26
-rw-r--r--app-arch/aptly/metadata.xml10
4 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 756b5386b47a..3fc9267a96a9 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/aptly/Manifest b/app-arch/aptly/Manifest
new file mode 100644
index 000000000000..ea020f669710
--- /dev/null
+++ b/app-arch/aptly/Manifest
@@ -0,0 +1,4 @@
+DIST aptly-1.5.0-deps.tar.xz 162455936 BLAKE2B 2b13929b9cd9238095e0d97cf77cdfb8abce88bbf2ae48dbd3e48d9f96a12658381203b51c1ee1d87b441360d5ca7745a12b2eef54b355213de2cb2d07d59d7c SHA512 9cfa90fb3ebee66fdf1d7b859ce8d43659260f987ceb3ece9a357f9c55dab948a0f4c431fc7b80c867a06f960810c7d6f75bea7e04cf2e81e4c7eeb2a3833e2c
+DIST aptly-1.5.0.tar.gz 8334792 BLAKE2B 605dfcf4a1289cc101f3596aaa67ad64a05ed64d11dae78d3cb0219a44ed1fcda57c3225e718d27d7de7cadc0a751ed1c607849949beb3a531efcce9e8247d08 SHA512 0b48059ccce5b16c3f4b7eb33522263e0d82c7310ff6f6f515cea94de4c32caedad541acdb1bf498877cfce487c5b525d123150a83f535d76a1e219c5770a0c0
+EBUILD aptly-1.5.0.ebuild 612 BLAKE2B 3eeaf95f1472c4d622008c781e87c8cb1609f223a78d5d1bbe9e19c25003a90110e7f1e798c7ede87721fb1c46c6515769b73d87d8fb6ab2e5d412056ada68c6 SHA512 5f0061101df314f16171e995093bc6459c29542cadf4fbb0010068d42b0b5735d9d85b372547a807563b4c29437191c4400660447eb2291dbdae36ac49246f8e
+MISC metadata.xml 307 BLAKE2B b6d1d396f5fc1441feb36adff61f524d2e745b1404ba05c4ad7ebc7242c31adb2283993d40f2b447713adeb457149bdb2c70cfb9f12e4d6c47e15f07852e157a SHA512 53921c190d268e4e35cd8bb727e085ab55193fa7e268c88258c56434308878d6da6604e50863b2b76183737caea5e4355594d9bf4e8abc00d7a6e3a2dd2ae9ec
diff --git a/app-arch/aptly/aptly-1.5.0.ebuild b/app-arch/aptly/aptly-1.5.0.ebuild
new file mode 100644
index 000000000000..831d99b1b2f3
--- /dev/null
+++ b/app-arch/aptly/aptly-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit go-module systemd
+
+DESCRIPTION="Debian repository management tool"
+HOMEPAGE="https://www.aptly.info/"
+
+SRC_URI="https://github.com/aptly-dev/aptly/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz
+ https://dev.gentoo.org/~zmedico/dist/${P}-deps.tar.xz"
+
+LICENSE="MIT Apache-2.0 BSD BSD-2 ISC MPL-2.0 WTFPL-2 ZLIB"
+RESTRICT+=" test"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_compile() {
+ emake install
+}
+
+src_install() {
+ dobin ~/go/bin/aptly
+ dodoc README.rst
+ systemd_dounit aptly.service aptly-api.service
+}
diff --git a/app-arch/aptly/metadata.xml b/app-arch/aptly/metadata.xml
new file mode 100644
index 000000000000..907cab2e50fb
--- /dev/null
+++ b/app-arch/aptly/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aptly-dev/aptly</remote-id>
+ </upstream>
+</pkgmetadata>