summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-15 00:09:17 +0100
commit6a7029e0f7370d4d5dfe9e31cc2719a870482392 (patch)
tree28c6c747114eaedfd2db81f86ac2ff3d7d13111e /app-arch
parent5e41a38157bb40e8513e8e34426e85faba672fe7 (diff)
gentoo auto-resync : 15:06:2024 - 00:09:17
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin18264 -> 18265 bytes
-rw-r--r--app-arch/lxqt-archiver/Manifest2
-rw-r--r--app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild50
3 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index c5415dc29382..ae6cb4dc2006 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/lxqt-archiver/Manifest b/app-arch/lxqt-archiver/Manifest
index 1718968fdf00..662a809ee1a9 100644
--- a/app-arch/lxqt-archiver/Manifest
+++ b/app-arch/lxqt-archiver/Manifest
@@ -1,5 +1,7 @@
DIST lxqt-archiver-0.9.0.tar.xz 183352 BLAKE2B 60443b7f4407b85bc1233f00ad2e46861c17281331d3b611021ca14be2e159befa0c8303d51b9021d35aa246d4fd9138ceb4f4b19cd6143438f8c3b976f9c40d SHA512 42ee097ae7fb17dbd00d9b94e8673664911c73bb5f353d08177c78d548eb24c39aa1daf57347eeefcb46ec63a8702c37f63ca2b42fd22bc85aed8f7a41585f3c
DIST lxqt-archiver-0.9.1.tar.xz 186600 BLAKE2B 365b849578f9f663ed7628c52c4c7205af10ea255dd131a94a6960c581111e02fedee01be0bd674d1ef71c9648cc5a58de1b548c972eb415cfae990e7045cfb4 SHA512 fd7862c85f6f93c870a4b28d2ed3705fcc0431e9b4d887f4fab6d860eddc5fe99d8a4c2f7cd2957c34d72b74a11b8eec49bbcca40dfee11f20f6a39f37e9ee00
+DIST lxqt-archiver-1.0.0.tar.xz 187944 BLAKE2B c28e0c7c5a41fa5a1e2d417239e5de0b33d3a84a2833fab7239f50ae1b7f426c2b7fd630a09cea24f2032183e2bdcc037276462fdab3719fb709fd9f51ea8afd SHA512 12552539cb7601c3c1422ed00d6fa8ed0ebed744ce8b7b4a3e3cc8bd59bf8df165008fa63b0ce173b58309001f35c33a219cd80e7568acf12c4c896320fc5061
EBUILD lxqt-archiver-0.9.0.ebuild 1288 BLAKE2B 0401a420bcd98e5118c541ba79c514401126b8a94151cf5aa988dcc7f111c7d89b41379e4df5bbfb8c2311f4bf10855db46d5597cf60e4d6f26c61f4e5761685 SHA512 55818ad06afba1827d359edf44211c00cec2e8c4412d1b7f31ecff03e49a9c1ae7545c05f7408fc137d003ab6b665c8a9227d15c034dc444bfe5ab830d3a3c6b
EBUILD lxqt-archiver-0.9.1.ebuild 1290 BLAKE2B 658005cc38bbc0dafa0ecf29e22743119393452e36365a41f9a113a015e62762dad2fb89a7c284c91f39bb3c6a7d4d57a913e89c625e1214a05c6f79a30c8e97 SHA512 0dab5b31df8a80a5c905d840dc5e1706b34d75bd988f94ee5e9eb7b97cf541da7d875df1f969de36d031f18cb98500702d8b5582bcbda7e6e33096da3eacfd71
+EBUILD lxqt-archiver-1.0.0.ebuild 1203 BLAKE2B 93eb2de7ac2d215b795cc602bbdcfaf4b582143657e98433dd07c6045ff33ce13e5f32f5fc29529e2aa872411bcb0c3708a068c72e021532b31a2411ad125215 SHA512 36b736ebf80efc2043922ff771c1ae3e51acfbcb44dad878e80161666899a20ad8b5c3d3cf2ed0e703f2e42d930865729589821c98a328b9ac211dfc06cc2506
MISC metadata.xml 330 BLAKE2B 1f25c787f9b43ef0ef62206ca9ab67dfab8b95b2786fc84248541159507290229b291b9f83541adc196b58a9dcad7c0f3abd18c5c899a98978dc72403386896d SHA512 12f4638550e157da50134bf6c7cb480bd49661b9655900efdbb12a023c4bd4cd13018d7caa672096329691cf8556f89c9d13d6710463048329c8e3bd5f04f6ee
diff --git a/app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild b/app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild
new file mode 100644
index 000000000000..6013e54464dd
--- /dev/null
+++ b/app-arch/lxqt-archiver/lxqt-archiver-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_PV="$(ver_cut 1-2)"
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt GUI File Archiver"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+
+BDEPEND="
+ >=dev-qt/qttools-6.6:6[linguist]
+ >=dev-util/lxqt-build-tools-2.0.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-libs/json-glib
+ >=dev-qt/qtbase-6.6:6[gui,widgets]
+ >=x11-libs/libfm-qt-2.0:=
+"
+RDEPEND="${DEPEND}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "Please note that this is only a graphical front-end, and additional"
+ elog "packages are needed to have support for specific file formats."
+ elog "For example, to be able to work with the 7-Zip format, the"
+ elog "'app-arch/p7zip' package may be used."
+ elog "For the full list of supported formats, see the 'README.md' file:"
+ elog "https://github.com/lxqt/lxqt-archiver/blob/master/README.md"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}