summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-04 08:06:08 +0100
commit2a8d2f71d1d9963368e0ef3d641d75979a689d12 (patch)
tree83e283f960ab2ebbc1a042b8ed6c37b78d47b37b /app-arch
parent8435c842b9e8fbb2bcc80397ab3aa655000459e2 (diff)
gentoo auto-resync : 04:07:2024 - 08:06:07
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/7zip/7zip-24.07.ebuild110
-rw-r--r--app-arch/7zip/Manifest3
-rw-r--r--app-arch/Manifest.gzbin18249 -> 18254 bytes
3 files changed, 113 insertions, 0 deletions
diff --git a/app-arch/7zip/7zip-24.07.ebuild b/app-arch/7zip/7zip-24.07.ebuild
new file mode 100644
index 000000000000..59e13dc0c5e5
--- /dev/null
+++ b/app-arch/7zip/7zip-24.07.ebuild
@@ -0,0 +1,110 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edos2unix flag-o-matic toolchain-funcs
+
+NO_DOT_PV=$(ver_rs 1- '')
+DESCRIPTION="Free file archiver for extremely high compression"
+HOMEPAGE="https://www.7-zip.org/ https://sourceforge.net/projects/sevenzip/"
+# linux-x64 tarball is only used for docs
+SRC_URI="
+ https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-src.tar.xz
+ https://downloads.sourceforge.net/sevenzip/7-Zip/${PV}/7z${NO_DOT_PV}-linux-x64.tar.xz
+"
+S="${WORKDIR}"
+
+LICENSE="LGPL-2 BSD rar? ( unRAR )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="uasm jwasm rar"
+REQUIRED_USE="?? ( uasm jwasm )"
+
+DOCS=( readme.txt History.txt License.txt )
+HTML_DOCS=( MANUAL )
+
+DEPEND="${RDEPEND}"
+BDEPEND="
+ uasm? ( dev-lang/uasm )
+ jwasm? ( dev-lang/jwasm )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-24.05-respect-build-env.patch"
+)
+
+# TODO(NRK): also build and install the library
+# TODO(NRK): make it so this package can be used as a drop-in replacement
+# for app-arch/p7zip ??
+
+pkg_setup() {
+ # instructions in DOC/readme.txt, Compiling 7-Zip for Unix/Linux
+ # TLDR; every combination of options (clang|gcc)+(asm/noasm)
+ # has a dedicated makefile & builddir
+ mfile="cmpl"
+ if tc-is-clang; then
+ mfile="${mfile}_clang"
+ bdir=c
+ elif tc-is-gcc; then
+ mfile="${mfile}_gcc"
+ bdir=g
+ else
+ die "Unsupported compiler: $(tc-getCC)"
+ fi
+ if use jwasm || use uasm ; then
+ mfile="${mfile}_x64"
+ bdir="${bdir}_x64"
+ fi
+ export mfile="${mfile}.mak"
+ export bdir
+}
+
+src_prepare() {
+ # patch doesn't deal with CRLF even if file+patch match
+ # not even with --ignore-whitespace, --binary or --force
+ pushd "./CPP/7zip" || die "Unable to switch directory"
+ edos2unix ./7zip_gcc.mak ./var_gcc{,_x64}.mak ./var_clang{,_x64}.mak
+ sed -i -e 's/-Werror //g' ./7zip_gcc.mak || die "Error removing -Werror"
+ popd >/dev/null || die "Unable to switch directory"
+
+ default
+}
+
+src_compile() {
+ pushd "./CPP/7zip/Bundles/Alone2" || die "Unable to switch directory"
+
+ # avoid executable stack when using uasm/jwasm, harmless otherwise
+ append-ldflags -Wl,-z,noexecstack
+ export G_CFLAGS=${CFLAGS}
+ export G_CXXFLAGS=${CXXFLAGS}
+ export G_LDFLAGS=${LDFLAGS}
+
+ local args=(
+ -f "../../${mfile}"
+ CC=$(tc-getCC)
+ CXX=$(tc-getCXX)
+ )
+ # NOTE: makefile doesn't check the value of DISABLE_RAR_COMPRESS, only
+ # whether it's defined or not. so in case user has `rar` enabled
+ # DISABLE_RAR_COMPRESS (and DISABLE_RAR) needs to stay undefined.
+ if ! use rar; then
+ # disables non-free rar code but allows listing and extracting
+ # non-compressed rar archives
+ args+=( DISABLE_RAR_COMPRESS=1 )
+ fi
+ if use jwasm; then
+ args+=( USE_JWASM=1 )
+ elif use uasm; then
+ args+=( MY_ASM=uasm )
+ fi
+
+ mkdir -p "${bdir}" || die # Bug: https://bugs.gentoo.org/933619
+ emake ${args[@]}
+ popd > /dev/null || die "Unable to switch directory"
+}
+
+src_install() {
+ dobin "./CPP/7zip/Bundles/Alone2/b/${bdir}/7zz"
+ einstalldocs
+}
diff --git a/app-arch/7zip/Manifest b/app-arch/7zip/Manifest
index 2e6ccfd95cfd..c9da034c5db3 100644
--- a/app-arch/7zip/Manifest
+++ b/app-arch/7zip/Manifest
@@ -6,7 +6,10 @@ DIST 7z2405-linux-x64.tar.xz 1553872 BLAKE2B d6c0bd4eb81f4112bfe50bf6affc68021b0
DIST 7z2405-src.tar.xz 1486772 BLAKE2B 609c7ae8b89e56e747ebfecb25108d8918138f48f0f2ed73183c76101ddd3615aafb9eb7823be0de2a434b450587e01f476d2ed092628a311b6e4ed091e06260 SHA512 d340adfa68e818dd3d3aa411780c81532fa37b6649178b81ec3739725f83e0bc3c01744612b2d467f4d0c2cc984dd35488406d7baee185cf372acebd9c0123a7
DIST 7z2406-linux-x64.tar.xz 1551724 BLAKE2B e4cc8141b074209b58018e6aeb4b91f140160d5d52e1fba59da2d0cfcd41c488cbfa4bda99bdedd4915ca3c3bcca50e7f7f4289f44ce120577c8b632d2f7bf07 SHA512 fce2b8e9f26f092209613dc058a267ddf24c474a80b7e9837014fdaeab53bb892b7181561ca90048ca593fe29e010b8221e078c9c3ab9815baf23bc9caf3e829
DIST 7z2406-src.tar.xz 1487008 BLAKE2B 0f8dd19a031520a9c233725e376bca06c91b9b513bc802a54b92ea046ae3dda69a293561938a1e4467d01333d46427bfee7a055c8b62cab7a9d04cf8262fe4eb SHA512 02c6d7d045ba0dc0e8533f471f3c138f0d6549b59594095cb81a2f0e602627bd6a49df3fd680e21400a908006121ff7ba370086db9bde639f79b821bb4c9707a
+DIST 7z2407-linux-x64.tar.xz 1554932 BLAKE2B 9229fdac09148c50032656743aba0f8ce1ec06b7fd2dad2c693dc299c5f83fc093ba047e9c3c3971bf4cc9387b0db52c84167202ed7fcecfcc6f5bc508d04ada SHA512 31b5bb832e73f3c2fd0437873fe6130b8d1bd1bea8320d1b27d06bf40dd737758732eb3664fab2c36417b96ffc5daca6607b6f1aefdaa9e697122da60e37a728
+DIST 7z2407-src.tar.xz 1488556 BLAKE2B 42b4f9553aaa4797e80a2d50073ff0e77b5261e50766f8c596a632fb013ac1514a2963f27b924485f07728d13a4536c69911867e3728e8f8604ec25fc4c6824e SHA512 0299e5c1e1dfd33ecf22077f812da1f25bf2146a713c7a7e2498d639520f21f029e853914e66a84d1edfc5d721e1f3d914a3171ab336a406a94bc82d5b2d8e5d
EBUILD 7zip-23.01.ebuild 2960 BLAKE2B 9abf731f224a0cf143bcb0d11c21ccbb66a1e1f5456872c48f9ed14ed7ef1fbc46588fdcdb5d9fb10bb5f74f7322de6724f73f58db9fdbdc2c0d13b7fe0bb403 SHA512 ed752a84f6db6670a4136c35f1e932b9f141bcd169c7c608a719fe4bf6a931afad98ea620cfd72aade5fb99f853885e72febaabc1dd1e43d48284cc1bfab45a3
EBUILD 7zip-24.05.ebuild 2960 BLAKE2B 9abf731f224a0cf143bcb0d11c21ccbb66a1e1f5456872c48f9ed14ed7ef1fbc46588fdcdb5d9fb10bb5f74f7322de6724f73f58db9fdbdc2c0d13b7fe0bb403 SHA512 ed752a84f6db6670a4136c35f1e932b9f141bcd169c7c608a719fe4bf6a931afad98ea620cfd72aade5fb99f853885e72febaabc1dd1e43d48284cc1bfab45a3
EBUILD 7zip-24.06.ebuild 2967 BLAKE2B f94c9ea2760fe533c5d2e5435f82297220d9257c09880e44ba94b1160c7de4bece261e278d9c53b8669d096cd9b0adb916d6b0dc368131d02266c97bc71415d6 SHA512 4738a2b71e36968d9c0f39d685d2da168781f0e5b38ca35c0db37bc5bd9465597a47b818f777520189fad5546d53137b667ebc18d030b2eb7d75e7bfb361ea56
+EBUILD 7zip-24.07.ebuild 2967 BLAKE2B f94c9ea2760fe533c5d2e5435f82297220d9257c09880e44ba94b1160c7de4bece261e278d9c53b8669d096cd9b0adb916d6b0dc368131d02266c97bc71415d6 SHA512 4738a2b71e36968d9c0f39d685d2da168781f0e5b38ca35c0db37bc5bd9465597a47b818f777520189fad5546d53137b667ebc18d030b2eb7d75e7bfb361ea56
MISC metadata.xml 967 BLAKE2B 5b54d1cc757cdc63407a51587389f9db032ae141fd9e19423185fd457f50c469ceb53095b128d8c6cd751cf3f0a87703dd36ba5d048dbfe9bea0ccd2354168b2 SHA512 c8c53c995f4bb5982461fa16dd50193f48c59aa15076bd78e38ccc4f0abf2190bf2b143df50e1c7911bd7814bd2ecb34892ee818b328764a9ff4ab2429718d37
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 5db04b200dbe..1cf736357a8e 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ