summaryrefslogtreecommitdiff
path: root/app-arch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-06 21:40:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-06 21:40:28 +0100
commit10e3aabd0e3e0accfc5cba9e7b06bf694512625f (patch)
tree7282f9514e821f650373f8dde70a36af84e8913b /app-arch
parenta52a3a626c1d57fc0b3dbf58e79a23e88c3dd4ff (diff)
gentoo auto-resync : 06:06:2023 - 21:40:28
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/Manifest.gzbin17414 -> 17416 bytes
-rw-r--r--app-arch/dump/Manifest1
-rw-r--r--app-arch/dump/dump-0.4.47-r2.ebuild96
3 files changed, 97 insertions, 0 deletions
diff --git a/app-arch/Manifest.gz b/app-arch/Manifest.gz
index 6646f1e06045..cee4cb37b7c3 100644
--- a/app-arch/Manifest.gz
+++ b/app-arch/Manifest.gz
Binary files differ
diff --git a/app-arch/dump/Manifest b/app-arch/dump/Manifest
index 2291bc648301..0cb19a025302 100644
--- a/app-arch/dump/Manifest
+++ b/app-arch/dump/Manifest
@@ -1,3 +1,4 @@
DIST dump-0.4b47.tar.gz 583380 BLAKE2B a5a6c507fc67451e6ce5117b28b9e97e45783059358c357e1f6d4b268437c8340f13e0d77e97631112824eca8205c49d206a8a7904bc3e00b1f0d5abb31418f7 SHA512 e9c567fe2ffad196b9657c551d83f7607758f3704cad6cb407514bbe2bc765c16968997dc3a5bc92b9eb5900fa5bd6e7cebc92c81afff53339fca92891a5259d
EBUILD dump-0.4.47-r1.ebuild 2171 BLAKE2B 45518c50773251da809311f41f4c0245660e023ffbf54b0a985d47e5668a57bfe66b73362e7244e2ba4a139034aa32aa754a0cd6a18d1c661b74ee459c69086d SHA512 e9e0a48ac2e2b30b243cc134543be272975dc8309ba8f2389ba6897b1c76a03801e22af11db2c064aa14b6c5d90869624f28549374d5659568d840dd894fa802
+EBUILD dump-0.4.47-r2.ebuild 2423 BLAKE2B 6ecac7f91fb600be878c96242936fb151142fde140043e1c36aaadd1fd5db087ba2f3359e6f5ae21068ca6d388af88c483dddc49d8dcbb63a38e0a8524cba627 SHA512 bd16f6f9224a6b4b801775e1f6c0f6e4d126ef50f69989b2526c62f4833ea3c3890ad1a0342853a75102291c7e67f3254e4c44073846a7b2e21cf72fd4b9d91c
MISC metadata.xml 443 BLAKE2B a993a4c9e17125bd2da2e0002c55443402e0873613f37f0c97ea62ea12ae3b97c6364546e8a06b539cd98df9edcc750daa2f99c2696fc78c06870e21df5b6e0f SHA512 5aca723c5ae7925c19f8f2c4839d560b4859691b25b646bec1fba0a9e98fe5aef88ee718f16c7095d046d3667052d09a40bbbb6c35bda8d7c73fea8af8ea8439
diff --git a/app-arch/dump/dump-0.4.47-r2.ebuild b/app-arch/dump/dump-0.4.47-r2.ebuild
new file mode 100644
index 000000000000..11b1136eccae
--- /dev/null
+++ b/app-arch/dump/dump-0.4.47-r2.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit readme.gentoo-r1
+
+MY_P="${PN}-$(ver_rs 2 b)"
+
+DESCRIPTION="Dump/restore ext2fs backup utilities"
+HOMEPAGE="https://dump.sourceforge.io/"
+SRC_URI="mirror://sourceforge/dump/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+# We keep uuid USE flag default dsiabled for this version. Don't forget
+# to default enable it for later versions as this is the upstream default.
+IUSE="bzip2 debug ermt lzo readline selinux sqlite ssl static test uuid zlib"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="
+ ermt? ( ssl )
+ ssl? ( zlib )
+ test? ( sqlite? ( uuid ) )"
+
+RDEPEND="
+ >=sys-fs/e2fsprogs-1.27:=
+ sys-apps/util-linux
+ bzip2? (
+ app-arch/bzip2:=
+ static? ( app-arch/bzip2[static-libs] )
+ )
+ zlib? ( >=sys-libs/zlib-1.1.4:= )
+ lzo? (
+ dev-libs/lzo:2=
+ static? ( dev-libs/lzo:2[static-libs] )
+ )
+ sqlite? ( dev-db/sqlite:3= )
+ ermt? ( dev-libs/openssl:0= )
+ ssl? ( dev-libs/openssl:0= )
+ readline? (
+ sys-libs/readline:0=
+ sys-libs/ncurses:=
+ static? ( sys-libs/ncurses:=[static-libs] )
+ )"
+DEPEND="${RDEPEND}
+ virtual/os-headers"
+BDEPEND="virtual/pkgconfig"
+
+src_configure() {
+ local myeconfargs=(
+ --with-dumpdatespath=/etc/dumpdates
+ --with-rmtpath='$(sbindir)/rmt'
+ --enable-blkid
+ $(use_enable bzip2)
+ $(use_enable debug)
+ $(use_enable ermt)
+ $(use_enable lzo)
+ $(use_enable readline)
+ $(use_enable selinux)
+ $(use_enable sqlite)
+ $(use_enable ssl)
+ $(use_enable static static-progs)
+ $(use_enable uuid)
+ $(use_enable zlib)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ mv "${ED}"/usr/sbin/{,dump-}rmt || die
+ mv "${ED}"/usr/share/man/man8/{,dump-}rmt.8 || die
+ use ermt && newsbin rmt/ermt dump-ermt
+
+ dodoc KNOWNBUGS MAINTAINERS REPORTING-BUGS
+ dodoc -r examples
+
+ # Don't install pre-compressed files
+ gunzip "${ED}"/usr/share/doc/${PF}/examples/cron_dump_to_disk/backupskel.tar.gz \
+ || die
+
+ local DOC_CONTENTS="dump has serious bugs
+ (see https://sourceforge.net/p/dump/bugs/162/ and
+ https://sourceforge.net/p/dump/bugs/174/). This tool should only
+ be used for restoring old backups, not for creating new ones.
+ \n\n${CATEGORY}/${PN} installs 'rmt' as 'dump-rmt'.
+ This is to avoid conflicts with app-arch/tar 'rmt'."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}