summaryrefslogtreecommitdiff
path: root/app-arch/zopfli/zopfli-1.0.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/zopfli/zopfli-1.0.1-r2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/zopfli/zopfli-1.0.1-r2.ebuild')
-rw-r--r--app-arch/zopfli/zopfli-1.0.1-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/zopfli/zopfli-1.0.1-r2.ebuild b/app-arch/zopfli/zopfli-1.0.1-r2.ebuild
new file mode 100644
index 000000000000..cb39213529a9
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.1-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/google/zopfli/"
+SRC_URI="https://github.com/google/zopfli/archive/${P}.tar.gz"
+
+S="${WORKDIR}/${PN}-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+DOCS=( CONTRIBUTORS README README.zopflipng )
+
+PATCHES=( "${FILESDIR}"/${P}-makefile.patch )
+
+# zopflipng statically links an exact version of LodePNG (https://github.com/lvandeve/lodepng)
+
+src_prepare() {
+ default
+ tc-export CC CXX
+}
+
+# The Makefile has no install phase
+src_install() {
+ dolib.so libzopfli.so*
+ doheader src/zopfli/zopfli.h
+
+ dobin ${PN}
+
+ # This version was erroneously not bumped to match ${PV}
+ dolib.so libzopflipng.so*
+ doheader src/zopflipng/zopflipng_lib.h
+
+ dobin zopflipng
+}