summaryrefslogtreecommitdiff
path: root/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild')
-rw-r--r--app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild b/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
new file mode 100644
index 000000000000..13820f174c00
--- /dev/null
+++ b/app-arch/zopfli/zopfli-1.0.0_p20140705.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils multilib toolchain-funcs vcs-snapshot
+
+DESCRIPTION="Very good, but slow, deflate or zlib compression"
+HOMEPAGE="https://github.com/Hello71/zopfli/"
+SRC_URI="https://github.com/Hello71/zopfli/archive/1c07f374419ccb352412fd6403acc2b59ab6cce7.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/1"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+
+src_prepare() {
+ tc-export CC CXX
+
+ epatch_user
+}
+
+src_install() {
+ emake DESTDIR="${D}" prefix="${EPREFIX}/usr" libdir="${EPREFIX}/usr/$(get_libdir)" install
+ dodoc CONTRIBUTORS README README.${PN}png
+}