summaryrefslogtreecommitdiff
path: root/app-arch/xdms/xdms-1.3.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/xdms/xdms-1.3.2-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/xdms/xdms-1.3.2-r1.ebuild')
-rw-r--r--app-arch/xdms/xdms-1.3.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/xdms/xdms-1.3.2-r1.ebuild b/app-arch/xdms/xdms-1.3.2-r1.ebuild
new file mode 100644
index 000000000000..3561bdcbd691
--- /dev/null
+++ b/app-arch/xdms/xdms-1.3.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="xDMS - Amiga DMS disk image decompressor"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/xdms"
+SRC_URI="http://zakalwe.fi/~shd/foss/xdms/${P}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ default
+ sed -i Makefile.in \
+ -e "s:COPYING::" \
+ -e "s:share/doc/xdms-{VERSION}:share/doc/xdms-${PF}:" || die
+ sed -i -e "s:-O2::" src/Makefile.in || die
+}
+
+src_configure() {
+ ./configure --prefix=/usr --package-prefix="${D}" || die
+}