summaryrefslogtreecommitdiff
path: root/app-arch/xarchiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-arch/xarchiver
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/Manifest2
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.17.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index d0f8a39c9a88..464ef2e950ed 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1,3 +1,5 @@
DIST xarchiver-0.5.4.15.tar.gz 1072943 BLAKE2B 6f80c8dba510bf5c05dfe5c8f12aafbd4f563861878c73b7da78562836ef4b85f9bc8e4ed7cda5d98c5e33a211a2677d163c2912f1bb605e0085627ca4ee5cbb SHA512 e5174241dd45dd6186d91b15a15b207a8b356480d9ce1a7b9ac2da167878cdb14316a3e7abf3f2aac8d41a02777df2131e205c7d5971a376ff7dd0ca70fbc82f
+DIST xarchiver-0.5.4.17.tar.gz 1077111 BLAKE2B f68f22258dbfaeb37333fab3d2ea1b06e23e143f90df6cd94f7601961636d1e5a929e1353ac956ac9a7341813593fcfb35d5197666dbb0920ddf63e4365f34e1 SHA512 5b19fd0fb90f99aee0ac2576bc4efce9ef4eef9119fc118815f6d925e3877c0895475fbdf7363d8adfb6371fb7fd73299ea3a7cb3b6d9fff19c89d1d287d3a84
EBUILD xarchiver-0.5.4.15.ebuild 1428 BLAKE2B 05941c387d97a5ff0e7e9e4c98c1c7a57118c562016213caaf0d464be9084787b9c9dab44cfac0cc982a3cb6c49473eabce5264b516952677d89a9adc57e2b4f SHA512 af14235bdcf1bf71033fcc1457e592fbaa2f7f6a5285a5740d8c6c530ee1f48df88e67ccb7f011253598dba2b33b901eaad150a6f0c9fcb98bb8ad00e482b424
+EBUILD xarchiver-0.5.4.17.ebuild 1325 BLAKE2B a8ba4fb6a0ad10190214c57bb8ae9b8e75ca21bcea7a7f58894fdb0337ca62151645a5e1300ec495cc2bad647243929d20c0bd83c2facdeb4c51856209ec94d5 SHA512 270b67aa43cdaa127d30dd6bfcf3a375e09fcb36489384c49dc391d8db0cdd1a10c1acc76e942e7126df5b5e395c1f2cdea30bb4791853f730be1eaf6d52dc6c
MISC metadata.xml 447 BLAKE2B 9427d1c1f2062c7efa986b9182cefd225dac542e30a254b787470a2060fa6c3838dadcde3c3fdc9b10aa99fde66a6928286bdb2ae80437bd5590a8899e3f99fb SHA512 35841081a561194fd9ce87cf0232f727e0a7e86caf3564c6551c412ba397f1b759cba10b977fb4d9148529aaab313275e3e8066bebaa0848bc30e6c466e38a93
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.17.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.17.ebuild
new file mode 100644
index 000000000000..019605f89c3a
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.17.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# older pigz versions have incompatible command-line processing
+# https://bugs.gentoo.org/661464
+RDEPEND=">=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+ !!<app-arch/pigz-2.4[symlink]"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}