summaryrefslogtreecommitdiff
path: root/app-arch/xarchiver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-arch/xarchiver
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-arch/xarchiver')
-rw-r--r--app-arch/xarchiver/Manifest2
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.15.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/app-arch/xarchiver/Manifest b/app-arch/xarchiver/Manifest
index 7fbc8299d28c..69a82c5388b2 100644
--- a/app-arch/xarchiver/Manifest
+++ b/app-arch/xarchiver/Manifest
@@ -1,3 +1,5 @@
DIST xarchiver-0.5.4.14.tar.gz 1081542 BLAKE2B 591d93dfbaa98164bc169105462155b09ed87dab8ad5adff6653e77673095a29d7f00cdaeed1b928039fe3cc5f668f8da46885905ae73d03f5b4c71dd279a7b4 SHA512 b38881e6cdfb402499efbd18ab25cac3869cd48ef96941a4bb3cb8b6b130a2317abe3b1d11bfc3d60e81eef7cafa34515fefc11e469443d96d139c2f09cf4498
+DIST xarchiver-0.5.4.15.tar.gz 1072943 BLAKE2B 6f80c8dba510bf5c05dfe5c8f12aafbd4f563861878c73b7da78562836ef4b85f9bc8e4ed7cda5d98c5e33a211a2677d163c2912f1bb605e0085627ca4ee5cbb SHA512 e5174241dd45dd6186d91b15a15b207a8b356480d9ce1a7b9ac2da167878cdb14316a3e7abf3f2aac8d41a02777df2131e205c7d5971a376ff7dd0ca70fbc82f
EBUILD xarchiver-0.5.4.14.ebuild 1438 BLAKE2B 4a065c6d80da446dbcae9ffc46d6d4aebedeee9d18a089e304dc237dcbf0196165ca52044966bd99a453d09b3a80d23080a673066fc929c47a3401b82df98583 SHA512 7d2f73efd16745e0ad5670aac5f3c5ed81ba9184d0aa47ef9410ec5d8ec0d12c27698605491db8687f4f4936c72ecdb1f6b37ed84742df0e40227f3e722e96a9
+EBUILD xarchiver-0.5.4.15.ebuild 1440 BLAKE2B 7f739370dfb24d5dcb37fcc2decadb1145d4e8c7b50303cc75650ce6c78a257669aa0679106e5c78a572cdce4771b5d7733b93a7ca55d114e4d88030ff4ac812 SHA512 1206ef834af47ca298e6bf28fcffebf59e925f89027b4dc9861c4b60ca4ff9a5d586fc0ff09b4ec4cef3048b91987f019d2eb47fcc3ade3a1704e638713dcc30
MISC metadata.xml 447 BLAKE2B 3ac670facb7c0034e1f079622c8c14e04a131e359e1cdbbc18b7cdd111a673651a97a7e35a430d13d80c1cf35e87f4aec0738836b60dd2837e4a77ff4e9485a3 SHA512 ccccc741a75658963153a71810ea9d8c25bfe49765f90a4aa5558ef8fef2abdd1e17d1c9ffb604a78deafeda1e5032b671c8f85a8189e6c89cf3f057dfec9a4a
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.15.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.15.ebuild
new file mode 100644
index 000000000000..e83f8d245d44
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.15.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver"
+SRC_URI="https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+# older pigz versions have incompatible command-line processing
+# https://bugs.gentoo.org/661464
+RDEPEND=">=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+ !!<app-arch/pigz-2.4[symlink]"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )"
+
+src_prepare() {
+ sed -e '/COPYING/d' -e '/NEWS/d' -i doc/Makefile.am || die
+ default
+ mkdir m4 || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/unarj app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}