summaryrefslogtreecommitdiff
path: root/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-04 11:28:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-04 11:28:04 +0100
commit47a1d2f184696819152c003a600beb058fbc4420 (patch)
treea85ea2840d8bb2bfaea292c4e2f363b663cc1ea1 /app-arch/xarchiver/xarchiver-0.5.4.21.ebuild
parent42564959cad787b3e82c0ebd8a8a6a59958e1370 (diff)
gentoo auto-resync : 04:05:2023 - 11:28:04
Diffstat (limited to 'app-arch/xarchiver/xarchiver-0.5.4.21.ebuild')
-rw-r--r--app-arch/xarchiver/xarchiver-0.5.4.21.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild b/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild
new file mode 100644
index 000000000000..7ac6a12c9715
--- /dev/null
+++ b/app-arch/xarchiver/xarchiver-0.5.4.21.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A GTK+ archive manager that can be used with Thunar"
+HOMEPAGE="https://github.com/ib/xarchiver/"
+SRC_URI="
+ https://github.com/ib/xarchiver/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc"
+
+DEPEND="
+ >=dev-libs/glib-2:=
+ x11-libs/gtk+:3=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ doc? (
+ app-text/docbook-xml-dtd
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxml2
+ dev-libs/libxslt
+ )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable doc)
+ )
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+
+ elog "You need external programs for some formats, including:"
+ elog "7zip - app-arch/p7zip"
+ elog "arj - app-arch/arj"
+ elog "lha - app-arch/lha"
+ elog "lzop - app-arch/lzop"
+ elog "rar - app-arch/unrar app-arch/rar"
+ elog "zip - app-arch/unzip app-arch/zip"
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}