summaryrefslogtreecommitdiff
path: root/app-arch/unshield
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/unshield
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/unshield')
-rw-r--r--app-arch/unshield/Manifest5
-rw-r--r--app-arch/unshield/metadata.xml7
-rw-r--r--app-arch/unshield/unshield-1.4.2.ebuild27
-rw-r--r--app-arch/unshield/unshield-1.4.ebuild30
4 files changed, 69 insertions, 0 deletions
diff --git a/app-arch/unshield/Manifest b/app-arch/unshield/Manifest
new file mode 100644
index 000000000000..7329db5552f9
--- /dev/null
+++ b/app-arch/unshield/Manifest
@@ -0,0 +1,5 @@
+DIST unshield-1.4.2.tar.gz 46051 BLAKE2B 76e8e724916f5c43c84b17db34f2c5905f99fe424679b9c9fef76e1892d0a2f90e6c195f1a02a8446473860578c34678e395f65cf5973019ed7be5d3dea14e84 SHA512 3ddd5df47198adade66acf89644efe3a1c87d60fcdf511f8e5c1fb29bbb07e77a9abc57a05b161ecb54a26a2a86242bbcba6e90df770b1325965ff5aa8eddf58
+DIST unshield-1.4.tar.gz 37199 BLAKE2B 7f32cdbac3dca8e5e7dfca7e9ae7d12066b0484a8e75f611af173ec12dfd03dfd0ee7b79d05e3c7fb45a3285bbbfacf6020ad100907345a1501b3a8de81c81bc SHA512 b09c29fa8e5785f2ca90b40105304802d00d201dde42ef4f5e4b5504ca8edf10da426c7ed1daa8c0685980f085eb20437162812a2068a0c03c0dfd240edbf944
+EBUILD unshield-1.4.2.ebuild 846 BLAKE2B f9528f21ca70da097527aa4f3b7beb2d1c3f18dbb181a0dcb4f512d05ceaca4a7ba6e8c095507a0428c851ea84b3a5832a3997f8274284721ab7daf375bbb8bb SHA512 99f96f2328ae4efe4dc1cc78014b12d630b69413e0f98823d9ad895d45bf3a7bfd96ea132105786699d165440cfc64fa1352f2cbca472699947fb88e3b732772
+EBUILD unshield-1.4.ebuild 932 BLAKE2B bf19ee8b959311ca950bf81a1d518386614f26dbc5fd799a065fb67847a4c98b9b081a5df3c4624c9bd721995531e56d3b1b41cd5e6d36ec07778bfbf37665d8 SHA512 81c169fa18106e9a4bbebe63ac9f3f4e43f9d4750091a33f65336e36f2995fb1382d5a02bb51b17fb403a06a77ad3a6c0bf47fffa783205b1e53720fc35254a9
+MISC metadata.xml 224 BLAKE2B 39d3ea8455cb2158a24af3db4266dd569cd7765eafa967c5ae2a2cc9f9ceec9d0a8928b5e99d9e5bc5f610501bb6129f1648d6560e0a4980ef9e026dc821a164 SHA512 3c955bc3bb3a290848f9cc01472321c321ad63b98a10eb1a7986024db98c099e5a18c628c6398b37c42e69d333fe88d74cca5c22293aba196991aa317e6ed670
diff --git a/app-arch/unshield/metadata.xml b/app-arch/unshield/metadata.xml
new file mode 100644
index 000000000000..417ce2a21afc
--- /dev/null
+++ b/app-arch/unshield/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="github">twogood/unshield</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/unshield/unshield-1.4.2.ebuild b/app-arch/unshield/unshield-1.4.2.ebuild
new file mode 100644
index 000000000000..1410d202234b
--- /dev/null
+++ b/app-arch/unshield/unshield-1.4.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+
+# OpenSSL (or LibreSSL) is detected at build time, and used to determine
+# whether or not a hand-rolled md5 implementation is used. The build
+# system prefers OpenSSL's implementation if it's available, and OpenSSL
+# is common enough, so we prefer it too. Since the dependency is
+# automagic (there's no way to hide it), we require Open/LibreSSL
+# unconditionally.
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
diff --git a/app-arch/unshield/unshield-1.4.ebuild b/app-arch/unshield/unshield-1.4.ebuild
new file mode 100644
index 000000000000..44fa7c700751
--- /dev/null
+++ b/app-arch/unshield/unshield-1.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="InstallShield CAB file extractor"
+HOMEPAGE="https://github.com/twogood/unshield"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc x86"
+
+# OpenSSL (or LibreSSL) is detected at build time, and used to determine
+# whether or not a hand-rolled md5 implementation is used. The build
+# system prefers OpenSSL's implementation if it's available, and OpenSSL
+# is common enough, so we prefer it too. Since the dependency is
+# automagic (there's no way to hide it), we require Open/LibreSSL
+# unconditionally.
+IUSE="libressl"
+
+DEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+# Without this, the build fails looking for unshield_config.h.
+CMAKE_IN_SOURCE_BUILD=y