summaryrefslogtreecommitdiff
path: root/app-arch/unarj/unarj-2.65.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/unarj/unarj-2.65.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/unarj/unarj-2.65.ebuild')
-rw-r--r--app-arch/unarj/unarj-2.65.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/unarj/unarj-2.65.ebuild b/app-arch/unarj/unarj-2.65.ebuild
new file mode 100644
index 000000000000..ec1cba73be8e
--- /dev/null
+++ b/app-arch/unarj/unarj-2.65.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Utility for opening arj archives"
+HOMEPAGE="http://www.arjsoftware.com/"
+SRC_URI="mirror://freebsd/ports/local-distfiles/ache/${P}.tgz"
+
+LICENSE="arj"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}"/${P}-CAN-2004-0947.patch
+ "${FILESDIR}"/${P}-sanitation.patch
+ "${FILESDIR}"/${P}-gentoo-fbsd.patch
+ "${FILESDIR}"/${PN}-2.65-Wformat-security.patch
+)
+
+src_configure() {
+ tc-export CC
+}
+
+src_install() {
+ dobin unarj
+ dodoc unarj.txt technote.txt
+}