summaryrefslogtreecommitdiff
path: root/app-arch/tarlz/tarlz-0.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
commit5b14ea000f5782ac047162ffc35ef8c3c0648b4a (patch)
tree9bd4130367f85e9308e6d6c6b12ba58759b5f789 /app-arch/tarlz/tarlz-0.23.ebuild
parent85261a4d217482e1c124937d57ec98a0aabaee59 (diff)
gentoo auto-resync : 25:09:2022 - 23:34:28
Diffstat (limited to 'app-arch/tarlz/tarlz-0.23.ebuild')
-rw-r--r--app-arch/tarlz/tarlz-0.23.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/tarlz/tarlz-0.23.ebuild b/app-arch/tarlz/tarlz-0.23.ebuild
new file mode 100644
index 000000000000..ac8108f138ea
--- /dev/null
+++ b/app-arch/tarlz/tarlz-0.23.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs unpacker
+
+DESCRIPTION="A parallel archiver combining tar and lzip"
+HOMEPAGE="https://www.nongnu.org/lzip/tarlz.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.lz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=app-arch/lzlib-1.12
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ $(unpacker_src_uri_depends)
+"
+
+src_configure() {
+ econf \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}" \
+ CPPFLAGS="${CPPFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+}