summaryrefslogtreecommitdiff
path: root/app-arch/stuffit/stuffit-5.2.0.611.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/stuffit/stuffit-5.2.0.611.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/stuffit/stuffit-5.2.0.611.ebuild')
-rw-r--r--app-arch/stuffit/stuffit-5.2.0.611.ebuild67
1 files changed, 67 insertions, 0 deletions
diff --git a/app-arch/stuffit/stuffit-5.2.0.611.ebuild b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
new file mode 100644
index 000000000000..2e6528ed2126
--- /dev/null
+++ b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_P="stuffit520.611linux-i386"
+
+DESCRIPTION="Aladdin Software's StuffIt and StuffIt Expander"
+HOMEPAGE="http://www.stuffit.com/"
+SRC_URI="http://my.smithmicro.com/downloads/files/${MY_P}.tar.gz"
+
+LICENSE="Stuffit"
+SLOT="0"
+KEYWORDS="-* x86 amd64"
+IUSE=""
+RESTRICT="fetch strip"
+
+S="${WORKDIR}"
+
+INSTALLDIR=/opt/stuffit
+
+pkg_nofetch() {
+ einfo "Please download stuffit from"
+ einfo "${SRC_URI}"
+ einfo "and put the file in ${DISTDIR}"
+ einfo
+ einfo "Note that StuffIt requires registration within 30 days,"
+ einfo "but StuffIt Expander is freeware."
+ einfo
+}
+
+src_install() {
+ # First do the binaries
+ exeinto ${INSTALLDIR}/bin
+ doexe bin/stuff
+ doexe bin/unstuff
+
+ # Now the registration binary
+ exeinto ${INSTALLDIR}/extra
+ doexe bin/register
+
+ # Now the documentation
+ docinto stuff
+ dodoc doc/stuff/{README,stuff.html}
+ docinto unstuff
+ dodoc doc/unstuff/{README,unstuff.html}
+
+ # And now the man pages
+ doman man/man1/*
+
+ # Also add the executables to the path
+ dodir /etc/env.d
+ cat > "${T}"/10stuffit <<- EOF || die
+ PATH="${EPREFIX}${INSTALLDIR}/bin"
+ ROOTPATH="${EPREFIX}${INSTALLDIR}/bin"
+ EOF
+ doenvd "${T}"/10stuffit
+}
+
+pkg_postinst() {
+ elog
+ elog "Reminder: StuffIt requires registration within 30 days."
+ elog "The registration program is located in ${INSTALLDIR}/extra"
+ elog
+ elog "The binaries are named 'stuff' and 'unstuff'"
+ elog
+}