summaryrefslogtreecommitdiff
path: root/app-arch/stenc/stenc-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-arch/stenc/stenc-1.1.1.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-arch/stenc/stenc-1.1.1.ebuild')
-rw-r--r--app-arch/stenc/stenc-1.1.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/stenc/stenc-1.1.1.ebuild b/app-arch/stenc/stenc-1.1.1.ebuild
new file mode 100644
index 000000000000..ab03524d5efc
--- /dev/null
+++ b/app-arch/stenc/stenc-1.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/scsitape/stenc.git"
+ S="${WORKDIR}/${P}/src"
+else
+ SRC_URI="https://github.com/scsitape/stenc/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="SCSI Tape Encryption Manager enables AES support for LTO drives"
+HOMEPAGE="https://github.com/scsitape/stenc/"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+DEPEND=""
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}