summaryrefslogtreecommitdiff
path: root/app-arch/rzip/rzip-2.1-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /app-arch/rzip/rzip-2.1-r4.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'app-arch/rzip/rzip-2.1-r4.ebuild')
-rw-r--r--app-arch/rzip/rzip-2.1-r4.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/rzip/rzip-2.1-r4.ebuild b/app-arch/rzip/rzip-2.1-r4.ebuild
new file mode 100644
index 000000000000..02cf14d9e94b
--- /dev/null
+++ b/app-arch/rzip/rzip-2.1-r4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Compression program for large files"
+HOMEPAGE="https://rzip.samba.org/"
+SRC_URI="https://rzip.samba.org/ftp/rzip/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+RDEPEND="app-arch/bzip2:="
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.1-darwin.patch
+ "${FILESDIR}"/${PN}-2.1-CVE-2017-8364.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_postinst() {
+ ewarn "Warning: Gentoo shipped a broken rzip for quite some time. During"
+ ewarn "compression of large files it didn't set the right file size, so"
+ ewarn "if you have any reason to believe that your archive was compressed "
+ ewarn "with an old Gentoo rzip, please refer to "
+ ewarn " https://bugs.gentoo.org/217552"
+ ewarn "for the rzip-handle-broken-archive.patch patch to rescue your"
+ ewarn "data."
+ ewarn
+ ewarn "We apologize for the inconvenience."
+}