summaryrefslogtreecommitdiff
path: root/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild')
-rw-r--r--app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild b/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild
new file mode 100644
index 000000000000..bbe23041901c
--- /dev/null
+++ b/app-arch/rpm2targz/rpm2targz-9.0.0.5g.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Convert a .rpm file to a .tar.gz archive"
+HOMEPAGE="http://www.slackware.com/config/packages.php"
+SRC_URI="mirror://gentoo/${P}.tar.xz"
+
+LICENSE="BSD-1"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="app-arch/cpio"
+DEPEND="app-arch/xz-utils"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install # need explicit install line #397835
+ dodoc *.README*
+}