summaryrefslogtreecommitdiff
path: root/app-arch/qpress/qpress-1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/qpress/qpress-1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/qpress/qpress-1.1.ebuild')
-rw-r--r--app-arch/qpress/qpress-1.1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/app-arch/qpress/qpress-1.1.ebuild b/app-arch/qpress/qpress-1.1.ebuild
new file mode 100644
index 000000000000..e7787c7973a5
--- /dev/null
+++ b/app-arch/qpress/qpress-1.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A portable file archiver using QuickLZ algorithm"
+HOMEPAGE="http://www.quicklz.com/"
+SRC_URI="http://www.quicklz.com/${PN}-${PV/./}-source.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+
+src_prepare() {
+ default
+
+ # Fix compilation with newer gcc
+ sed -i '1i #include <unistd.h>' qpress.cpp || die
+ cp "${FILESDIR}/makefile" "${S}" || die
+}
+
+src_install() {
+ dobin ${PN}
+}