summaryrefslogtreecommitdiff
path: root/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-30 01:11:30 +0000
commit76dfef0cec9170000357d2f354e412daf48941fc (patch)
tree56647120c0ee20ab3494475c86722034cd194b02 /app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
parentccf84bcd604130256d1377cd58f0a634ae6ee20f (diff)
gentoo resync : 30.12.2017
Diffstat (limited to 'app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild')
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild25
1 files changed, 10 insertions, 15 deletions
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
index ca26b16fbcfb..f28c6df42ec4 100644
--- a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="2"
+EAPI=6
-inherit eutils toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="utility to test and create .sfv files and create .par files"
HOMEPAGE="http://pure-sfv.sourceforge.net/"
@@ -15,20 +15,15 @@ KEYWORDS="amd64 ~hppa ppc x86"
IUSE=""
RESTRICT="test"
-DEPEND=""
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}"/${PN}-0.3-fix-build-system.patch )
-S="${WORKDIR}"
-
-src_prepare() {
- sed -i Makefile -e "s:-Werror -O2 -g::"
- epatch "${FILESDIR}"/${P}-asneeded.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die "emake failed"
+src_configure() {
+ append-cflags -Wall -Wno-unused
+ tc-export CC
}
src_install() {
- dobin pure-sfv || die "dobin failed"
- dodoc ReadMe.txt
+ dobin pure-sfv
+ newdoc ReadMe.txt README
}