summaryrefslogtreecommitdiff
path: root/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild')
-rw-r--r--app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
new file mode 100644
index 000000000000..ca26b16fbcfb
--- /dev/null
+++ b/app-arch/pure-sfv/pure-sfv-0.3-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="utility to test and create .sfv files and create .par files"
+HOMEPAGE="http://pure-sfv.sourceforge.net/"
+SRC_URI="mirror://sourceforge/pure-sfv/${PN}_${PV}_src.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc x86"
+IUSE=""
+RESTRICT="test"
+
+DEPEND=""
+
+S="${WORKDIR}"
+
+src_prepare() {
+ sed -i Makefile -e "s:-Werror -O2 -g::"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ dobin pure-sfv || die "dobin failed"
+ dodoc ReadMe.txt
+}