summaryrefslogtreecommitdiff
path: root/app-arch/plzip/plzip-1.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /app-arch/plzip/plzip-1.8.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'app-arch/plzip/plzip-1.8.ebuild')
-rw-r--r--app-arch/plzip/plzip-1.8.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/plzip/plzip-1.8.ebuild b/app-arch/plzip/plzip-1.8.ebuild
new file mode 100644
index 000000000000..f9fedd5f8ae5
--- /dev/null
+++ b/app-arch/plzip/plzip-1.8.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/plzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CXX="$(tc-getCXX)"
+ CPPFLAGS="${CPPFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}