summaryrefslogtreecommitdiff
path: root/app-arch/plzip/plzip-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/plzip/plzip-1.6.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/plzip/plzip-1.6.ebuild')
-rw-r--r--app-arch/plzip/plzip-1.6.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/plzip/plzip-1.6.ebuild b/app-arch/plzip/plzip-1.6.ebuild
new file mode 100644
index 000000000000..1d8e4b07cda7
--- /dev/null
+++ b/app-arch/plzip/plzip-1.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Parallel lzip compressor"
+HOMEPAGE="http://www.nongnu.org/lzip/plzip.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="app-arch/lzlib:0="
+DEPEND=${RDEPEND}
+
+src_configure() {
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CXX="$(tc-getCXX)"
+ CPPFLAGS="${CPPFLAGS}"
+ CXXFLAGS="${CXXFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}