summaryrefslogtreecommitdiff
path: root/app-arch/pax
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/pax
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/pax')
-rw-r--r--app-arch/pax/Manifest4
-rw-r--r--app-arch/pax/files/pax-20160306-glibc-to-linux.patch38
-rw-r--r--app-arch/pax/metadata.xml5
-rw-r--r--app-arch/pax/pax-20161104.ebuild63
4 files changed, 110 insertions, 0 deletions
diff --git a/app-arch/pax/Manifest b/app-arch/pax/Manifest
new file mode 100644
index 000000000000..7dd30700df50
--- /dev/null
+++ b/app-arch/pax/Manifest
@@ -0,0 +1,4 @@
+AUX pax-20160306-glibc-to-linux.patch 852 BLAKE2B ebca2d148954e511d3a4f79ef96cadad0eb93c35e9959a2fe6833c8371aa8c2d20f2a471ef3e8e19efbebd2f15ae1ff66ab976191166603998cf4b4ccbc705ce SHA512 f6ee4abbc2f9a422a735fc6a09098a6bec9b855211bcdce088cc7362cb88def65ec574d91ad7cc48ee055e0438d481ed1e4b6ff650419ce3c7c09449ab82b69a
+DIST paxmirabilis-20161104.cpio.gz 148061 BLAKE2B 997a126d3048488e1a4e49ff9753de2ebdbe75b7daedbea8c95ab5f1902d4768d4b12b13fa684cb2a7c2fe8470ab60e19ea3f9430429a6a4e6e1d57993130fd4 SHA512 42ec8365a5efb9ffb9d383cece39ffaac85c1c8d69856ec557a5567cf0d28d98a0f2d4b7fed53572366eba12c71111cc80b591d51c6a19a3e6437efb62af33ce
+EBUILD pax-20161104.ebuild 1456 BLAKE2B f467bffa0c0b8696d48b5f2161d75de38d21dac88cfc05cabe84ea16ccc1f691336ecb00016e22c5c99f626331d19abebf8b944ff81337669ea19503f3fb4a77 SHA512 0e79f2be36f84d4717d820e56a6b57a9b955a7b95881a3c28f298d6749659bdc16a68c1b48e19bdc592a6344b8859956918f05544f790f1a21250bfdf2b870fb
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-arch/pax/files/pax-20160306-glibc-to-linux.patch b/app-arch/pax/files/pax-20160306-glibc-to-linux.patch
new file mode 100644
index 000000000000..eec6624eedc2
--- /dev/null
+++ b/app-arch/pax/files/pax-20160306-glibc-to-linux.patch
@@ -0,0 +1,38 @@
+--- a/cache.c
++++ b/cache.c
+@@ -195,7 +195,7 @@
+ * No entry for this uid, we will add it
+ */
+ if (!pwopn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setpwent();
+ #elif !defined(__INTERIX)
+ setpassent(1);
+@@ -265,7 +265,7 @@
+ * No entry for this gid, we will add it
+ */
+ if (!gropn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setgrent();
+ #elif !defined(__INTERIX) && !defined(__CYGWIN__)
+ setgroupent(1);
+@@ -336,7 +336,7 @@
+ }
+
+ if (!pwopn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setpwent();
+ #elif !defined(__INTERIX)
+ setpassent(1);
+@@ -403,7 +403,7 @@
+ }
+
+ if (!gropn) {
+-#if defined(__GLIBC__)
++#if defined(__GLIBC__) || defined(__linux__)
+ setgrent();
+ #elif !defined(__INTERIX) && !defined(__CYGWIN__)
+ setgroupent(1);
diff --git a/app-arch/pax/metadata.xml b/app-arch/pax/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-arch/pax/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>
diff --git a/app-arch/pax/pax-20161104.ebuild b/app-arch/pax/pax-20161104.ebuild
new file mode 100644
index 000000000000..c9fc9875ca5c
--- /dev/null
+++ b/app-arch/pax/pax-20161104.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit unpacker toolchain-funcs flag-o-matic
+
+DESCRIPTION="pax (Portable Archive eXchange) is the POSIX standard archive tool"
+HOMEPAGE="https://www.mirbsd.org/pax.htm"
+SRC_URI="https://www.mirbsd.org/MirOS/dist/mir/cpio/paxmirabilis-${PV}.cpio.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86"
+
+RDEPEND="
+ dev-libs/libbsd
+ elibc_musl? ( sys-libs/fts-standalone )
+"
+DEPEND="
+ ${RDEPEND}
+ $(unpacker_src_uri_depends)
+"
+PATCHES=(
+ "${FILESDIR}/${PN}-20160306-glibc-to-linux.patch"
+)
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ # Newer C libraries omit this include from sys/types.h.
+ sed -i '1i#include <sys/sysmacros.h>' extern.h || die
+ default
+}
+
+src_configure() {
+ tc-export CC PKG_CONFIG
+}
+
+src_compile() {
+ use elibc_musl && append-ldflags "-lfts"
+
+ # We can't rely on LFS flags as it uses the fts.h interface which lacks 64-bit support.
+ set -- \
+ ${CC} ${CPPFLAGS} ${CFLAGS} \
+ -DPAX_SAFE_PATH=\"/bin:/usr/bin\" \
+ -DHAVE_STRLCPY -DHAVE_VIS -DHAVE_STRMODE \
+ -DLONG_OFF_T -DHAVE_LINKAT \
+ $(${PKG_CONFIG} --cflags libbsd-overlay) \
+ -Wall ${LDFLAGS} *.c -o ${PN} \
+ $(${PKG_CONFIG} --libs libbsd-overlay)
+ echo "$@"
+ "$@" || die
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+
+ dosym pax /usr/bin/paxcpio
+ newman cpio.1 paxcpio.1
+
+ dosym pax /usr/bin/paxtar
+ newman tar.1 paxtar.1
+}