summaryrefslogtreecommitdiff
path: root/app-arch/pack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-24 23:32:34 +0100
commit83c7eb1835fcfdf7072b953d23ab34f03c7e8ed6 (patch)
treed44aefcc259a6d52e3d3b0c9929f52aedd24d001 /app-arch/pack
parent7138219e3c9446bf981ff17f5609f42130bec414 (diff)
gentoo auto-resync : 24:09:2022 - 23:32:34
Diffstat (limited to 'app-arch/pack')
-rw-r--r--app-arch/pack/Manifest3
-rw-r--r--app-arch/pack/metadata.xml11
-rw-r--r--app-arch/pack/pack-0.0.0.1.ebuild35
3 files changed, 49 insertions, 0 deletions
diff --git a/app-arch/pack/Manifest b/app-arch/pack/Manifest
new file mode 100644
index 000000000000..19f94246b32d
--- /dev/null
+++ b/app-arch/pack/Manifest
@@ -0,0 +1,3 @@
+DIST pack-0bd29ccae2662ef9ae1fabe707d84e4f84b36d53.tar.gz 3833 BLAKE2B f597746aa99e1cc59af3dd86a030458a2498a0649aae8f7bf9ac008c0bb6a0a26af62e5a4e76c6f8b49b5f0a6e19c0d6714c2a548231a6ce103c361b227757b9 SHA512 a75eb599aa0abcec9d151d5af7128bbbc13f7687dcc15ec5843dffd5e1084598ebabc6c1981a6ee225855435b5c4693ee4c7ad62f4e36f5e0de8205591d42439
+EBUILD pack-0.0.0.1.ebuild 727 BLAKE2B 79e010e3a0a336023a6b6d79748267e9736e1da7a04850410a37abfef81eb3045cabe7a52866b40f7befe590a604470fdcca288402a8ca668e19916d58703ca2 SHA512 3585da053551e332588cbf4295d7b561a6290f0a4e18e23522c8934a6ff5cb7af8bdf66071d61fb8fa0f647a26b46f16ccece7108b721e8496ad64bdd277a496
+MISC metadata.xml 326 BLAKE2B b2ec56467e83000fc934f07c5dc4dffd4e889de6f2e3001fc7073e3eed1b70498f37071a8178ccad72e99c49fbd0a0017d098d6b6875374a7eacdd5f2796951a SHA512 686fac4eb18f3cb7d7c815cf26bfd7ff460279635aa4514c050672059dfe58cf4483ff8a8a5e0df434029313b0061bee6f49c6d2305795567e1aa913f79a1d7c
diff --git a/app-arch/pack/metadata.xml b/app-arch/pack/metadata.xml
new file mode 100644
index 000000000000..daafb9559e2f
--- /dev/null
+++ b/app-arch/pack/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">koalaman/pack</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-arch/pack/pack-0.0.0.1.ebuild b/app-arch/pack/pack-0.0.0.1.ebuild
new file mode 100644
index 000000000000..e02651bdace9
--- /dev/null
+++ b/app-arch/pack/pack-0.0.0.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit haskell-cabal
+
+EGIT_COMMIT="0bd29ccae2662ef9ae1fabe707d84e4f84b36d53"
+MY_P=${PN}-${EGIT_COMMIT}
+DESCRIPTION="Haskell implementation of pack compression from the early 1980s"
+HOMEPAGE="https://github.com/koalaman/pack/"
+SRC_URI="
+ https://github.com/koalaman/pack/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-lang/ghc:=
+"
+BDEPEND="
+ >=dev-haskell/cabal-1.10
+"
+
+CABAL_FILE=${S}/pack-compression.cabal
+
+src_prepare() {
+ sed -i -e '/base/s:&& <4.10::' "${CABAL_FILE}" || die
+ haskell-cabal_src_prepare
+ cabal-mksetup
+}