summaryrefslogtreecommitdiff
path: root/app-arch/lzlib/lzlib-1.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/lzlib/lzlib-1.9.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/lzlib/lzlib-1.9.ebuild')
-rw-r--r--app-arch/lzlib/lzlib-1.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/lzlib/lzlib-1.9.ebuild b/app-arch/lzlib/lzlib-1.9.ebuild
new file mode 100644
index 000000000000..72bec4c5725b
--- /dev/null
+++ b/app-arch/lzlib/lzlib-1.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Library for lzip compression"
+HOMEPAGE="http://www.nongnu.org/lzip/lzlib.html"
+SRC_URI="http://download.savannah.gnu.org/releases/lzip/${PN}/${P}.tar.gz"
+
+LICENSE="libstdc++" # fancy form of GPL-2+ with library exception
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+src_configure() {
+ local myconf=(
+ --enable-shared
+ --disable-static
+ --disable-ldconfig
+ --prefix="${EPREFIX}"/usr
+ --libdir='$(prefix)'/$(get_libdir)
+ CC="$(tc-getCC)"
+ CFLAGS="${CFLAGS}"
+ CPPFLAGS="${CPPFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ # not autotools-based
+ ./configure "${myconf[@]}" || die
+}