summaryrefslogtreecommitdiff
path: root/app-arch/lziprecover/lziprecover-1.23.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-arch/lziprecover/lziprecover-1.23.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-arch/lziprecover/lziprecover-1.23.ebuild')
-rw-r--r--app-arch/lziprecover/lziprecover-1.23.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-arch/lziprecover/lziprecover-1.23.ebuild b/app-arch/lziprecover/lziprecover-1.23.ebuild
new file mode 100644
index 000000000000..cd4f742fd89c
--- /dev/null
+++ b/app-arch/lziprecover/lziprecover-1.23.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Lziprecover is a data recovery tool and decompressor for lzip compressed files"
+HOMEPAGE="https://www.nongnu.org/lzip/lziprecover.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/${PN}/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_configure() {
+ # not autotools-based
+ ./configure \
+ --prefix="${EPREFIX}"/usr \
+ CXX="$(tc-getCXX)" \
+ CPPFLAGS="${CPPFLAGS}" \
+ CXXFLAGS="${CXXFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die
+}