summaryrefslogtreecommitdiff
path: root/app-arch/lha/lha-114i_p20210328.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-17 19:45:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-17 19:45:55 +0100
commit59fb6ea4eff116f078307a57217645762b78aba7 (patch)
treebc4b009c0fb67e5716ad01ba8306a486fe4744ed /app-arch/lha/lha-114i_p20210328.ebuild
parent197f0639ca0a63b397552e059e2a992d39e09e55 (diff)
gentoo auto-resync : 17:06:2023 - 19:45:55
Diffstat (limited to 'app-arch/lha/lha-114i_p20210328.ebuild')
-rw-r--r--app-arch/lha/lha-114i_p20210328.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-arch/lha/lha-114i_p20210328.ebuild b/app-arch/lha/lha-114i_p20210328.ebuild
new file mode 100644
index 000000000000..ee095d4e1141
--- /dev/null
+++ b/app-arch/lha/lha-114i_p20210328.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+MY_COMMIT="26950220c9c7590fd603ecaa54a12a52371affed"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="https://github.com/jca02266/lha https://lha.osdn.jp"
+SRC_URI="https://github.com/jca02266/lha/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-file-list-from-stdin.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc olddoc/ChangeLog Hacking_of_LHa
+}