summaryrefslogtreecommitdiff
path: root/app-arch/lha/lha-114i_p20201004.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /app-arch/lha/lha-114i_p20201004.ebuild
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'app-arch/lha/lha-114i_p20201004.ebuild')
-rw-r--r--app-arch/lha/lha-114i_p20201004.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-arch/lha/lha-114i_p20201004.ebuild b/app-arch/lha/lha-114i_p20201004.ebuild
new file mode 100644
index 000000000000..64f5b7ac288d
--- /dev/null
+++ b/app-arch/lha/lha-114i_p20201004.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_COMMIT="7c3cd95fdf0d2f9198bb779561724cd314bc39a6"
+
+DESCRIPTION="Utility for creating and opening lzh archives"
+HOMEPAGE="https://github.com/jca02266/lha https://lha.osdn.jp"
+SRC_URI="https://github.com/jca02266/lha/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="lha"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~m68k-mint"
+
+S="${WORKDIR}/${PN}-${MY_COMMIT}"
+
+PATCHES=(
+ "${FILESDIR}"/${P/_p*}-file-list-from-stdin.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ if [[ ${CHOST} == *-interix* ]]; then
+ export ac_cv_header_inttypes_h=no
+ export ac_cv_func_iconv=no
+ fi
+
+ default
+}
+
+src_install() {
+ default
+ dodoc olddoc/ChangeLog Hacking_of_LHa
+}