summaryrefslogtreecommitdiff
path: root/app-arch/lha/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/lha/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/lha/files')
-rw-r--r--app-arch/lha/files/lha-114i-file-list-from-stdin.patch29
-rw-r--r--app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch11
2 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/lha/files/lha-114i-file-list-from-stdin.patch b/app-arch/lha/files/lha-114i-file-list-from-stdin.patch
new file mode 100644
index 000000000000..4bd0d17d7527
--- /dev/null
+++ b/app-arch/lha/files/lha-114i-file-list-from-stdin.patch
@@ -0,0 +1,29 @@
+Index: src/lharc.c
+===================================================================
+--- src/lharc.c (revision 773)
++++ src/lharc.c (working copy)
+@@ -561,7 +561,7 @@
+ if (!isatty(1) && cmd == CMD_ADD)
+ quiet = TRUE;
+ }
+-#if 0 /* Comment out; IMHO, this feature is useless. by Koji Arai */
++#ifndef MINGW32
+ else {
+ if (argc == 3 && !isatty(0)) { /* 1999.7.18 */
+ /* Bug(?) on MinGW, isatty() return 0 on Cygwin console.
+Index: configure.ac
+===================================================================
+--- configure.ac (revision 773)
++++ configure.ac (working copy)
+@@ -289,6 +289,11 @@
+ [Define to 1 if you want to ignore dot files with -X command line switch])
+ fi
+
++AC_MINGW32
++if test "x$MINGW32" = xyes; then
++ AC_DEFINE(MINGW32, 1, [Define to 1 if we're being compiled with MinGW.])
++fi
++
+ AC_CONFIG_FILES([Makefile src/Makefile man/Makefile olddoc/Makefile])
+ AC_CONFIG_FILES([tests/Makefile tests/lha-test])
+ AC_OUTPUT
diff --git a/app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch b/app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch
new file mode 100644
index 000000000000..b57a1c9c6158
--- /dev/null
+++ b/app-arch/lha/files/lha-114i-fix-getopt_long-declaration.patch
@@ -0,0 +1,11 @@
+--- src/getopt_long.c.orig 2013-12-18 16:05:59.789413528 -0600
++++ src/getopt_long.c 2013-12-18 16:06:01.200420472 -0600
+@@ -64,7 +64,7 @@
+
+ #ifndef USE_GNU
+ #include <stdio.h>
+-#include <getopt_long.h>
++#include "getopt_long.h"
+
+ char *optarg;
+ int optind;