summaryrefslogtreecommitdiff
path: root/app-arch/gcab/gcab-1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-06 16:14:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-06 16:14:21 +0100
commit5c92379e3a6732ff2855a56c60576983ae42e288 (patch)
treecfc3b84baaef518de09d10b5305a3f4abbc16dd7 /app-arch/gcab/gcab-1.6.ebuild
parent8e3281f71945b4cccca5a44f2f467f3bff4ac45c (diff)
gentoo auto-resync : 06:07:2023 - 16:14:21
Diffstat (limited to 'app-arch/gcab/gcab-1.6.ebuild')
-rw-r--r--app-arch/gcab/gcab-1.6.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/app-arch/gcab/gcab-1.6.ebuild b/app-arch/gcab/gcab-1.6.ebuild
new file mode 100644
index 000000000000..1bd60c38adb9
--- /dev/null
+++ b/app-arch/gcab/gcab-1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson vala xdg
+
+DESCRIPTION="Library and tool for working with Microsoft Cabinet (CAB) files"
+HOMEPAGE="https://wiki.gnome.org/msitools https://gitlab.gnome.org/GNOME/gcab"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+IUSE="gtk-doc +introspection test vala"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ >=dev-libs/glib-2.62.0:2
+ sys-libs/zlib
+ introspection? ( >=dev-libs/gobject-introspection-1.54:= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ >=dev-util/gtk-doc-1.14
+ app-text/docbook-xml-dtd:4.3
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+ use vala && vala_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use gtk-doc docs)
+ $(meson_use introspection)
+ -Dnls=true
+ $(meson_use vala vapi)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ )
+ meson_src_configure
+}