summaryrefslogtreecommitdiff
path: root/app-arch/drpm
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-07 17:57:54 +0000
commitbc75b42f7650c33ffdb61e5e29b0b96cb9111932 (patch)
tree867908c0cf83e6015a5b1544cfdc4e17f1c13753 /app-arch/drpm
parentb3fef92e618039dc93153a93176184a49606c74a (diff)
gentoo auto-resync : 07:03:2023 - 17:57:54
Diffstat (limited to 'app-arch/drpm')
-rw-r--r--app-arch/drpm/Manifest5
-rw-r--r--app-arch/drpm/drpm-0.5.1.ebuild48
-rw-r--r--app-arch/drpm/drpm-9999.ebuild46
-rw-r--r--app-arch/drpm/files/drpm-0.5.1-c99.patch18
-rw-r--r--app-arch/drpm/metadata.xml18
5 files changed, 135 insertions, 0 deletions
diff --git a/app-arch/drpm/Manifest b/app-arch/drpm/Manifest
new file mode 100644
index 000000000000..da7f59c2d8ea
--- /dev/null
+++ b/app-arch/drpm/Manifest
@@ -0,0 +1,5 @@
+AUX drpm-0.5.1-c99.patch 577 BLAKE2B b3356702f5acbfd19338c4fa00dc9a04bf896ca002b728e59bdd05326f7053ea688e56ce78b2a60d026fe90c73e4dbd83e256b9f8513035cf9a1335d19ab7bc4 SHA512 cd46f911bea051979de4e9fb633a4d5179f870af32de5bc8f487bc201bc3be18ccfc0838a12233920fe6acc0a917b2804d9d0e3f67c7bf4f7d87808ef97d3fe5
+DIST drpm-0.5.1.tar.gz 138766 BLAKE2B dd64d925fa0e3975e2ca6f87fcddf10e376241d6b69a0f682cc5d6c006ef6aba7c021bcb98d049f4ce171b1561f36a07701e9eb47e0ac3c8315ee2d6d774c7c7 SHA512 5d4be3148075c6e0c560f97169a14e669a01ed48ef9228d8fc299b54da653ddec1110971a5b2bf455cc72cd1538d8c95e817428f73dd1d7ce07773822c05b3c5
+EBUILD drpm-0.5.1.ebuild 1020 BLAKE2B 80333d0c2bcdfeff82db852e63ecbcea2bbc78e397b5d13da09eb4c997ecffdbd9b5fb28b936d203945f15502910a9ac97260183ae02e62afca67e2972cfc9a8 SHA512 2da92edd368fb7d9eee1f6cf9e92091ecfcb07e6190e893d9db748e24a6ef1d51807d6116341e21fcdcee42468d3a5fe1cd098ab5d5b8d72b5f392f54e2605fa
+EBUILD drpm-9999.ebuild 978 BLAKE2B 6a877cbaa779a00fe8fe580ced07806f58cf01c19cedef1064870d4fe35a57de19b8e88f628dcaa5de42609f83eb3d77544e4b0d2ba6127c3563012642c3b406 SHA512 25260fe9a18b75d272dd148159d8d880797b4960ca61fe94b537fb3ada4ff99bc8b61cfd2bc187ddfcb08175de3eb7ac86ab2842a206ab4730454e772032aafe
+MISC metadata.xml 623 BLAKE2B e76fda9b7e7e5e63fef82fcb80872ef84ed4adc68c07e812db5d5b460a55b467f525bdf0f1e8ab86b1de1b192067cf47ea0e2cc2e1cec8c814f01d20d7237216 SHA512 e55feb7f5b8c63a0bacfc4aca64d4684e196fb41f850e8c3fb64449ce8ce91603dc8bbdb5c916b47ac2d1cf78148d16b3fd8cd789cd4afea320ac9f8f9d019d3
diff --git a/app-arch/drpm/drpm-0.5.1.ebuild b/app-arch/drpm/drpm-0.5.1.ebuild
new file mode 100644
index 000000000000..8cb80e38d855
--- /dev/null
+++ b/app-arch/drpm/drpm-0.5.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A library for making, reading and applying deltarpm packages"
+HOMEPAGE="https://github.com/rpm-software-management/drpm"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rpm-software-management/drpm/"
+else
+ SRC_URI="https://github.com/rpm-software-management/drpm/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="lzip test zstd"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/rpm
+ app-arch/xz-utils
+ dev-libs/openssl:=
+ sys-libs/zlib
+ lzip? ( app-arch/lzlib )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
+ test? ( dev-util/cmocka )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-c99.patch )
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_LZLIB_DEVEL=$(usex lzip ON OFF)
+ -DWITH_ZSTD=$(usex zstd ON OFF)
+ -DENABLE_TESTS=$(usex test ON OFF)
+ )
+
+ cmake_src_configure
+}
diff --git a/app-arch/drpm/drpm-9999.ebuild b/app-arch/drpm/drpm-9999.ebuild
new file mode 100644
index 000000000000..668173c3e540
--- /dev/null
+++ b/app-arch/drpm/drpm-9999.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="A library for making, reading and applying deltarpm packages"
+HOMEPAGE="https://github.com/rpm-software-management/drpm"
+if [[ ${PV} = 9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/rpm-software-management/drpm/"
+else
+ SRC_URI="https://github.com/rpm-software-management/drpm/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+
+IUSE="lzip test zstd"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ app-arch/bzip2:=
+ app-arch/rpm
+ app-arch/xz-utils
+ dev-libs/openssl:=
+ sys-libs/zlib
+ lzip? ( app-arch/lzlib )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${DEPEND}
+ test? ( dev-util/cmocka )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DHAVE_LZLIB_DEVEL=$(usex lzip ON OFF)
+ -DWITH_ZSTD=$(usex zstd ON OFF)
+ -DENABLE_TESTS=$(usex test ON OFF)
+ )
+
+ cmake_src_configure
+}
diff --git a/app-arch/drpm/files/drpm-0.5.1-c99.patch b/app-arch/drpm/files/drpm-0.5.1-c99.patch
new file mode 100644
index 000000000000..208284f53cff
--- /dev/null
+++ b/app-arch/drpm/files/drpm-0.5.1-c99.patch
@@ -0,0 +1,18 @@
+https://github.com/rpm-software-management/drpm/commit/0bde9b7711a2fa8b811830cadfc979365f9362c6
+From: Florian Weimer <fweimer@redhat.com>
+Date: Thu, 12 Jan 2023 08:17:19 +0100
+Subject: [PATCH] C99 compatibility fix for drpm_write.c
+
+Include <string.h> for various string functions. This avoids
+implicit function declarations and resulting build failures with
+future compilers.
+--- a/src/drpm_write.c
++++ b/src/drpm_write.c
+@@ -23,6 +23,7 @@
+
+ #include <stdio.h>
+ #include <stdint.h>
++#include <string.h>
+ #include <fcntl.h>
+ #include <openssl/md5.h>
+ #include <rpm/rpmlib.h>
diff --git a/app-arch/drpm/metadata.xml b/app-arch/drpm/metadata.xml
new file mode 100644
index 000000000000..b43a6f0c5f62
--- /dev/null
+++ b/app-arch/drpm/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>Matt.Jolly@footclan.ninja</email>
+ <name>Matt Jolly</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="lzip">Enable <pkg>app-arch/lzip</pkg> decompression support via <pkg>app-arch/lzlib</pkg></flag>
+ </use>
+ <upstream>
+ <remote-id type="github">rpm-software-management/drpm</remote-id>
+ </upstream>
+</pkgmetadata>