summaryrefslogtreecommitdiff
path: root/app-arch/dpkg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/dpkg
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/dpkg')
-rw-r--r--app-arch/dpkg/Manifest6
-rw-r--r--app-arch/dpkg/dpkg-1.19.0.5.ebuild87
-rw-r--r--app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch10
-rw-r--r--app-arch/dpkg/files/dpkg-1.18.12-flags.patch11
-rw-r--r--app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch28
-rw-r--r--app-arch/dpkg/metadata.xml11
6 files changed, 153 insertions, 0 deletions
diff --git a/app-arch/dpkg/Manifest b/app-arch/dpkg/Manifest
new file mode 100644
index 000000000000..bf11fd113626
--- /dev/null
+++ b/app-arch/dpkg/Manifest
@@ -0,0 +1,6 @@
+AUX dpkg-1.18.12-dpkg_buildpackage-test.patch 215 BLAKE2B 9890d9f9bf0f2229f73d5639f1118fe32426485a6056c43cb4f443c3fa143a915c4a84ac6f484d2a1a1ad813344b9765d809b6e18cdc35191aca2151783e00a0 SHA512 c31aa285a9d896ea313ce7d04a959767811019781fb747714630d91b56c631557ea64716e6c0ff20f6f60da67ff8c143cc8697d7b482a2e387ca4712908d9154
+AUX dpkg-1.18.12-flags.patch 416 BLAKE2B c7fe40b28793420afa0b895585cc14a675f9be68784beef7965fe6e971f6b2d6ecaa7c8bae51bb9f774c9517a618bff85b723052360224952cbdd2b74759b42e SHA512 6c86e8519ab4a05a2c15a658f41c0da14429c4fba0fcd364426afce7db03cd886a69de3f04f167d0f7b6d36a05252455864c11b14f58baab0a4536249331369c
+AUX dpkg-1.18.12-rsyncable.patch 1245 BLAKE2B e1488cc6a6807d38ec7218ae6651b0d919fbc3ee5e2837540f91cf80229e669a6fe24d6de1c4bd1c1debdc34a0c04a2bbc6a21eb964032f24526986678eb1b14 SHA512 743f4780b4c93e53924836fae96d59c2f1098dae6ef683b2b30146ab0345109718a507486f86ff96cda5b705aff858da563cdc0d40c965bf964cafe7105994ae
+DIST dpkg_1.19.0.5.tar.xz 4557428 BLAKE2B 99c31705bfad1cfa024366c788264f4e747a7143f87c581730797975303c1054003e41fd65ecf80df1dc053ba87c0e8449ec574ddcb158228b41ae57a23db18f SHA512 60d7198ffe6ea759c30ad82143b3107d41ce59224b853cb5a7beb79af0de6ba6a69414c365e6b3555a0a9c60e3cf9b543a3a448d80a734be38ccecb77ae963a9
+EBUILD dpkg-1.19.0.5.ebuild 1845 BLAKE2B b6320665601e48f808499ad616aec40b0c7be70673561120eb963065e87a05f1f2e8e0f1fccedcd80fdcc98ff7239a07e7f9ee75396288058521099af94189f6 SHA512 54b06dd32e8a95fffb89a3f8e160d4156002fa51d02fb8648966eadfdc9e43d999dfb6d42c4eabc68f4b8c64b73c171221c1de3154b06e1ce180739a35e66f13
+MISC metadata.xml 339 BLAKE2B e4de06c58c3013dcb9ca8065c85811113f04df7c75283e405ea8670c8323eda1488d662b8281a4afed93795ee038ec6c4a4b5eb08316d4472913e08a67a03060 SHA512 c3fbabc925c3e99f26c6441cdea9626dc93520f2a8d3c5e45bfa7e51d42095295624f0f82377240f0c11580a9eccc5b5b15bf149ce6cfa36960e52f8c77aa61b
diff --git a/app-arch/dpkg/dpkg-1.19.0.5.ebuild b/app-arch/dpkg/dpkg-1.19.0.5.ebuild
new file mode 100644
index 000000000000..c269dcbcc850
--- /dev/null
+++ b/app-arch/dpkg/dpkg-1.19.0.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils multilib autotools toolchain-funcs
+
+DESCRIPTION="Package maintenance system for Debian"
+HOMEPAGE="https://packages.qa.debian.org/dpkg"
+SRC_URI="mirror://debian/pool/main/d/${PN}/${P/-/_}.tar.xz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-solaris ~x86-solaris"
+IUSE="+bzip2 +lzma nls selinux test unicode +update-alternatives +zlib"
+
+RDEPEND="
+ >=dev-lang/perl-5.14.2:=
+ bzip2? ( app-arch/bzip2 )
+ lzma? ( app-arch/xz-utils )
+ selinux? ( sys-libs/libselinux )
+ zlib? ( >=sys-libs/zlib-1.1.4 )
+"
+DEPEND="
+ ${RDEPEND}
+ app-arch/xz-utils
+ sys-devel/flex
+ virtual/pkgconfig
+ nls? (
+ app-text/po4a
+ >=sys-devel/gettext-0.18.2
+ )
+ test? (
+ dev-perl/IO-String
+ dev-perl/Test-Pod
+ virtual/perl-Test-Harness
+ )
+"
+
+DOCS=(
+ ChangeLog
+ THANKS
+ TODO
+)
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.18.12-dpkg_buildpackage-test.patch
+ "${FILESDIR}"/${PN}-1.18.12-flags.patch
+ "${FILESDIR}"/${PN}-1.18.12-rsyncable.patch
+)
+
+src_prepare() {
+ use nls && strip-linguas -i po
+
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC
+ econf \
+ $(use_enable nls) \
+ $(use_enable unicode) \
+ $(use_enable update-alternatives) \
+ $(use_with bzip2 libbz2) \
+ $(use_with lzma liblzma) \
+ $(use_with selinux libselinux) \
+ $(use_with zlib libz) \
+ --disable-compiler-warnings \
+ --disable-dselect \
+ --disable-silent-rules \
+ --disable-start-stop-daemon \
+ --localstatedir="${EPREFIX}"/var \
+ --without-libmd
+}
+
+src_compile() {
+ emake AR=$(tc-getAR)
+}
+
+src_install() {
+ default
+
+ keepdir /usr/$(get_libdir)/db/methods/{mnt,floppy,disk}
+ keepdir /usr/$(get_libdir)/db/{alternatives,info,methods,parts,updates}
+
+ prune_libtool_files
+}
diff --git a/app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch b/app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch
new file mode 100644
index 000000000000..e9716758d41b
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.18.12-dpkg_buildpackage-test.patch
@@ -0,0 +1,10 @@
+--- a/scripts/Makefile.am
++++ b/scripts/Makefile.am
+@@ -238,7 +238,6 @@
+ t/Dpkg_Source_Package.t \
+ t/Dpkg_Dist_Files.t \
+ t/dpkg_source.t \
+- t/dpkg_buildpackage.t \
+ t/merge_changelogs.t \
+ t/mk.t \
+ $(nil)
diff --git a/app-arch/dpkg/files/dpkg-1.18.12-flags.patch b/app-arch/dpkg/files/dpkg-1.18.12-flags.patch
new file mode 100644
index 000000000000..bee7dd729941
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.18.12-flags.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -182,8 +182,6 @@
+ # Checks for the build machinery.
+ AC_DEFINE([LIBDPKG_VOLATILE_API], [1], [Acknowledge the volatility of the API.])
+ DPKG_COMPILER_WARNINGS
+-DPKG_COMPILER_OPTIMIZATIONS
+-DPKG_LINKER_OPTIMIZATIONS
+ DPKG_ARCHITECTURE
+ AC_DEFINE([PACKAGE_RELEASE], [PACKAGE_VERSION " (" ARCHITECTURE ")"],
+ [Define the project release information, version and architecture])
diff --git a/app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch b/app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch
new file mode 100644
index 000000000000..69802da67092
--- /dev/null
+++ b/app-arch/dpkg/files/dpkg-1.18.12-rsyncable.patch
@@ -0,0 +1,28 @@
+--- a/scripts/Dpkg/Compression.pm
++++ b/scripts/Dpkg/Compression.pm
+@@ -81,20 +81,12 @@
+ };
+
+ #
+-# XXX: The gzip package in Debian at some point acquired a Debian-specific
+-# --rsyncable option via a vendor patch. Which is not present in most of the
+-# major distributions, dpkg downstream systems, nor gzip upstream, who have
+-# stated they will most probably not accept it because people should be using
+-# pigz instead.
++# If gzip supports --rsyncable (version >=1.7 or the Debian patched variant),
++# we use it. Sadly a non-compliant gzip will not complain about the argument
++# when it does not understand it, so we can only print out the usage and infer
++# --rsyncable support from that.
+ #
+-# This option should have never been accepted in dpkg, ever. But removing it
+-# now would probably cause demands for tarring and feathering. In addition
+-# we cannot use the Dpkg::Vendor logic because that would cause circular
+-# module dependencies. The whole affair is pretty disgusting really.
+-#
+-# Check the perl Config to discern Debian and hopefully derivatives too.
+-#
+-if ($Config{cf_by} eq 'Debian Project') {
++if (system("gzip --help 2>&1 | grep -q -- --rsyncable") == 0) {
+ push @{$COMP->{gzip}->{comp_prog}}, '--rsyncable';
+ }
+
diff --git a/app-arch/dpkg/metadata.xml b/app-arch/dpkg/metadata.xml
new file mode 100644
index 000000000000..029c83c94699
--- /dev/null
+++ b/app-arch/dpkg/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+<email>deb-tools@gentoo.org</email>
+<name>Gentoo Debian Tools Project</name>
+</maintainer>
+<use>
+<flag name="update-alternatives">Install update-alternatives</flag>
+</use>
+</pkgmetadata>