summaryrefslogtreecommitdiff
path: root/app-arch/deb2targz/deb2targz-1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/deb2targz/deb2targz-1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/deb2targz/deb2targz-1-r2.ebuild')
-rw-r--r--app-arch/deb2targz/deb2targz-1-r2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/deb2targz/deb2targz-1-r2.ebuild b/app-arch/deb2targz/deb2targz-1-r2.ebuild
new file mode 100644
index 000000000000..521a65f9698c
--- /dev/null
+++ b/app-arch/deb2targz/deb2targz-1-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+inherit base
+
+DESCRIPTION="Convert a .deb file to a .tar.gz archive"
+HOMEPAGE="http://www.miketaylor.org.uk/tech/deb/"
+SRC_URI="http://www.miketaylor.org.uk/tech/deb/${PN}"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND=""
+RDEPEND="dev-lang/perl"
+
+S=${WORKDIR}
+PATCHES=( "${FILESDIR}/${PN}-any-data.patch" )
+
+src_unpack() {
+ cp "${DISTDIR}/${PN}" "${S}"
+}
+
+src_install() {
+ dobin ${PN}
+}