summaryrefslogtreecommitdiff
path: root/app-arch/clzip/clzip-1.13.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /app-arch/clzip/clzip-1.13.ebuild
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'app-arch/clzip/clzip-1.13.ebuild')
-rw-r--r--app-arch/clzip/clzip-1.13.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-arch/clzip/clzip-1.13.ebuild b/app-arch/clzip/clzip-1.13.ebuild
new file mode 100644
index 000000000000..571001a3d9fe
--- /dev/null
+++ b/app-arch/clzip/clzip-1.13.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="C language version of lzip"
+HOMEPAGE="https://www.nongnu.org/lzip/clzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/clzip/${P/_/-}.tar.gz"
+S="${WORKDIR}/${P/_/-}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ # not autotools-based
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CPPFLAGS="${CPPFLAGS}"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ ./configure "${myconf[@]}" || die
+}