summaryrefslogtreecommitdiff
path: root/app-arch/cksfv/cksfv-1.3.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /app-arch/cksfv/cksfv-1.3.15.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'app-arch/cksfv/cksfv-1.3.15.ebuild')
-rw-r--r--app-arch/cksfv/cksfv-1.3.15.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/cksfv/cksfv-1.3.15.ebuild b/app-arch/cksfv/cksfv-1.3.15.ebuild
new file mode 100644
index 000000000000..82027ff3bdc6
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.15.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.3.15-destdir.patch
+)
+
+src_configure() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --prefix="${EPREFIX}"/usr \
+ --bindir="${EPREFIX}"/usr/bin \
+ --mandir="${EPREFIX}"/usr/share/man || die
+}