summaryrefslogtreecommitdiff
path: root/app-arch/cksfv/cksfv-1.3.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/cksfv/cksfv-1.3.14.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/cksfv/cksfv-1.3.14.ebuild')
-rw-r--r--app-arch/cksfv/cksfv-1.3.14.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-arch/cksfv/cksfv-1.3.14.ebuild b/app-arch/cksfv/cksfv-1.3.14.ebuild
new file mode 100644
index 000000000000..52041fde4aa9
--- /dev/null
+++ b/app-arch/cksfv/cksfv-1.3.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="SFV checksum utility (simple file verification)"
+HOMEPAGE="http://zakalwe.fi/~shd/foss/cksfv/"
+SRC_URI="http://zakalwe.fi/~shd/foss/cksfv/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE=""
+
+src_configure() {
+ # note: not an autoconf configure script
+ ./configure \
+ --compiler="$(tc-getCC)" \
+ --prefix="${EPREFIX}"/usr \
+ --package-prefix="${D}" \
+ --bindir="${EPREFIX}"/usr/bin \
+ --mandir="${EPREFIX}"/usr/share/man || die
+}
+
+src_install() {
+ emake install
+ dodoc ChangeLog README TODO
+}