summaryrefslogtreecommitdiff
path: root/app-arch/bzip3
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-20 16:18:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-20 16:18:45 +0100
commit2ffbfc63824a9e437090fb3c744670dd45369ae0 (patch)
treead31a5650e31f93490157943681bb982f8a4520c /app-arch/bzip3
parent399fa07bfac673a8846466b16c76549e329b55b8 (diff)
gentoo auto-resync : 20:05:2023 - 16:18:45
Diffstat (limited to 'app-arch/bzip3')
-rw-r--r--app-arch/bzip3/Manifest2
-rw-r--r--app-arch/bzip3/bzip3-1.3.1.ebuild32
2 files changed, 34 insertions, 0 deletions
diff --git a/app-arch/bzip3/Manifest b/app-arch/bzip3/Manifest
index 029ff99831a7..bfa332c4b42e 100644
--- a/app-arch/bzip3/Manifest
+++ b/app-arch/bzip3/Manifest
@@ -1,3 +1,5 @@
DIST bzip3-1.3.0.tar.xz 276724 BLAKE2B 4b9ddd4da193cc784265eb2584804cfe7ddb55947634dab9068f7df8d0f7ee8684b3ce1cc50df355780aa8514462d23e93ff637ce2ca552f3d09b32bf1edcde2 SHA512 3777f6f0c337b5014b510c97ca3d19c77e7e474482d9e83143186ab593967fcec3e19163b32b03e6d8243838091f24e45eca245e35f0a6e5e713f29873ad62c4
+DIST bzip3-1.3.1.tar.xz 277248 BLAKE2B 37044fae19a2743d2e5bd48c65f034578ccd30c316d9c19c0c8786f1248babe1dcb942cc18d3a65e0756210b551af8c7a15a1675d98dbd77d4832beff0598a9a SHA512 41616eaa53422eb5bb8780db731ecd0371599e688622810be5d1fac04aa489d212db3273a5f0d15702507c8c92b36e9a4006c52bc67da7ac6ce41c73ff412e51
EBUILD bzip3-1.3.0.ebuild 780 BLAKE2B c0beeaff4442ba49098444f5b0c04625180a4529776ac9c3b73cf5c9cdde95229c5e42b6db53cae58952b83c7aef907f83ab366e80958f24ba5f3bb3697640f9 SHA512 f68707c80a45818b97de6210cb137b26129ae5e90d57aded24c99a83817ce3e67c6b77b90bbd4a5b8329140dc76754b48d60503e50df16f26f11b944fca25440
+EBUILD bzip3-1.3.1.ebuild 782 BLAKE2B e2e032db4b8b2a8ec53f240c3dd78e9863ee88d9ee9cef1b48fa7f573b0d0510b3426d4d6fd56ee969aceeeb8351990e7e9d701ee0572baec969c4ae8b0ea3b3 SHA512 e9ecd0a9932d41902bb232d4b6e6862a627b15f50d48bf70450e4b55341dde203fc22327894faf41f09bd0711ebe4bdda2d324ece79f1deedd6070dfd9d10ba2
MISC metadata.xml 879 BLAKE2B eacb925ae4939be72ae25f0f333d8c8e1c08b2fd7946e27dfadd214b8fd5f27eef3f141f9ca911cf89151245f2fa11c7a8c5459c63badbfaf71e62aaca6d67f4 SHA512 963eae34b110b883993959f97a84c5fbaae914e009d024379d8b83ad02b335f3d7404ecd9020e291a38e78cb358dd4d0ff1b4b8f3604a2cc719e9d82ebee1e50
diff --git a/app-arch/bzip3/bzip3-1.3.1.ebuild b/app-arch/bzip3/bzip3-1.3.1.ebuild
new file mode 100644
index 000000000000..33aa6e59599d
--- /dev/null
+++ b/app-arch/bzip3/bzip3-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="A better and stronger spiritual successor to BZip2"
+HOMEPAGE="https://github.com/kspalaiologos/bzip3"
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/kspalaiologos/${PN}.git"
+else
+ SRC_URI="https://github.com/kspalaiologos/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm64 ~loong ~x86"
+fi
+
+LICENSE="LGPL-3+"
+SLOT="0"
+
+src_configure() {
+ # ./configure script will default to Clang if it is found on the system,
+ # force the use of CC selected by the user with CC=$(tc-getCC)
+ econf CC=$(tc-getCC)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}