summaryrefslogtreecommitdiff
path: root/app-arch/bzip2/bzip2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /app-arch/bzip2/bzip2-9999.ebuild
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'app-arch/bzip2/bzip2-9999.ebuild')
-rw-r--r--app-arch/bzip2/bzip2-9999.ebuild63
1 files changed, 63 insertions, 0 deletions
diff --git a/app-arch/bzip2/bzip2-9999.ebuild b/app-arch/bzip2/bzip2-9999.ebuild
new file mode 100644
index 000000000000..1b4bac424b04
--- /dev/null
+++ b/app-arch/bzip2/bzip2-9999.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson multilib-minimal
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="https://gitlab.com/federicomenaquintero/bzip2"
+if [[ "${PV}" == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/federicomenaquintero/bzip2.git"
+else
+ SRC_URI=""
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
+fi
+LICENSE="BZIP2"
+SLOT="0/1" # subslot = SONAME
+
+IUSE="static-libs"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Ddefault_library=$(usex static-libs both shared)
+ # Requires whole tex stack
+ -Ddocs="disabled"
+ )
+
+ meson_src_configure
+}
+
+multilib_src_compile() {
+ meson_src_compile
+}
+
+multilib_src_install() {
+ meson_src_install
+
+ if multilib_is_native_abi ; then
+ gen_usr_ldscript -a bz2
+
+ dodir /bin
+ mv "${ED}"/usr/bin/bzip2 "${ED}"/bin || die
+ fi
+}
+
+multilib_src_install_all() {
+ # move "important" bzip2 binaries to /bin and use the shared libbz2.so
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+
+ dosym bzdiff /usr/bin/bzcmp
+ dosym bzmore /usr/bin/bzless
+ local x
+ for x in bz{e,f}grep ; do
+ dosym bzgrep /usr/bin/${x}
+ done
+
+ dosym bzip2.1 /usr/share/man/man1/bzip2recover.1
+
+ local DOCS=( AUTHORS NEWS{,-pre-1.0.7} README.md )
+ einstalldocs
+}