summaryrefslogtreecommitdiff
path: root/app-arch/bzip2/bzip2-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /app-arch/bzip2/bzip2-9999.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'app-arch/bzip2/bzip2-9999.ebuild')
-rw-r--r--app-arch/bzip2/bzip2-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/app-arch/bzip2/bzip2-9999.ebuild b/app-arch/bzip2/bzip2-9999.ebuild
index ac95fff0d7be..579f0b8f44dd 100644
--- a/app-arch/bzip2/bzip2-9999.ebuild
+++ b/app-arch/bzip2/bzip2-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -12,7 +12,7 @@ if [[ "${PV}" == 9999 ]] ; then
EGIT_REPO_URI="https://gitlab.com/federicomenaquintero/bzip2.git"
else
SRC_URI=""
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
fi
LICENSE="BZIP2"
SLOT="0/1" # subslot = SONAME
@@ -36,6 +36,13 @@ multilib_src_compile() {
multilib_src_install() {
meson_src_install
+ # Install libbz2.so.1.0 due to accidental soname change in 1.0.7.
+ # Reference: 98da0ad82192d21ad74ae52366ea8466e2acea24.
+ # OK to remove one year after 2020-04-11.
+ if [[ ! -L "${ED}/usr/$(get_libdir)/libbz2.so.1.0" ]]; then
+ dosym libbz2.so.1 "/usr/$(get_libdir)/libbz2.so.1.0"
+ fi
+
if multilib_is_native_abi ; then
gen_usr_ldscript -a bz2