summaryrefslogtreecommitdiff
path: root/app-arch/brotli/brotli-1.0.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /app-arch/brotli/brotli-1.0.7.ebuild
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'app-arch/brotli/brotli-1.0.7.ebuild')
-rw-r--r--app-arch/brotli/brotli-1.0.7.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/app-arch/brotli/brotli-1.0.7.ebuild b/app-arch/brotli/brotli-1.0.7.ebuild
index 554f1fd3ffee..4debaa969ab4 100644
--- a/app-arch/brotli/brotli-1.0.7.ebuild
+++ b/app-arch/brotli/brotli-1.0.7.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
DISTUTILS_OPTIONAL="1"
DISTUTILS_IN_SOURCE_BUILD="1"
-inherit cmake-multilib distutils-r1 eapi7-ver
+inherit cmake-multilib distutils-r1
DESCRIPTION="Generic-purpose lossless compression algorithm"
HOMEPAGE="https://github.com/google/brotli"
@@ -29,7 +29,7 @@ if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/google/${PN}.git"
inherit git-r3
else
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
+ KEYWORDS="alpha amd64 ~arm arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~x64-macos ~x86-macos ~x64-solaris"
SRC_URI="https://github.com/google/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
fi
@@ -40,7 +40,6 @@ src_prepare() {
multilib_src_configure() {
local mycmakeargs=(
- -DBUILD_SHARED_LIBS=ON
-DBUILD_TESTING="$(usex test)"
)
cmake-utils_src_configure