summaryrefslogtreecommitdiff
path: root/app-arch/arj/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-arch/arj/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-arch/arj/files')
-rw-r--r--app-arch/arj/files/arj-3.10.22-darwin.patch41
-rw-r--r--app-arch/arj/files/arj-3.10.22-glibc2.10.patch12
-rw-r--r--app-arch/arj/files/arj-3.10.22-implicit-declarations.patch33
-rw-r--r--app-arch/arj/files/arj-3.10.22-interix.patch45
4 files changed, 131 insertions, 0 deletions
diff --git a/app-arch/arj/files/arj-3.10.22-darwin.patch b/app-arch/arj/files/arj-3.10.22-darwin.patch
new file mode 100644
index 000000000000..a09c30d3126d
--- /dev/null
+++ b/app-arch/arj/files/arj-3.10.22-darwin.patch
@@ -0,0 +1,41 @@
+--- arj-3.10.22/environ.c
++++ arj-3.10.22/environ.c
+@@ -58,7 +58,7 @@
+ #include <sys/ioctl.h>
+ #include <sys/statfs.h>
+ #include <sys/statvfs.h>
+- #elif defined(__FreeBSD__)||defined(__NetBSD__)
++ #elif defined(__FreeBSD__)||defined(__NetBSD__)||defined(__APPLE__)
+ #include <sys/param.h>
+ #include <sys/mount.h>
+ #elif defined(__QNXNTO__)
+--- arj-3.10.22/gnu/configure.in
++++ arj-3.10.22/gnu/configure.in
+@@ -62,6 +62,11 @@
+ DLL_FLAGS="-shared -export-dynamic"
+ LD_STRIP="gnu/stripgcc.lnk"
+ ;;
++*darwin*)
++ # not ELF
++ DLL_EXT=".dylib"
++ DLL_FLAGS=""
++ ;;
+ interix3*)
+ # not ELF
+ DLL_FLAGS="-shared"
+--- arj-3.10.22/arjcrypt.c
++++ arj-3.10.22/arjcrypt.c
+@@ -329,6 +329,13 @@
+ }
+ #endif
+
++#if defined(__APPLE__)
++int main()
++{
++ return(0);
++}
++#endif
++
+ /* External entry */
+
+ #if TARGET==DOS
diff --git a/app-arch/arj/files/arj-3.10.22-glibc2.10.patch b/app-arch/arj/files/arj-3.10.22-glibc2.10.patch
new file mode 100644
index 000000000000..4de45e1ea568
--- /dev/null
+++ b/app-arch/arj/files/arj-3.10.22-glibc2.10.patch
@@ -0,0 +1,12 @@
+diff -ruN arj-3.10.22.orig/fardata.c arj-3.10.22/fardata.c
+--- arj-3.10.22.orig/fardata.c 2004-04-17 04:39:42.000000000 -0700
++++ arj-3.10.22/fardata.c 2009-05-27 19:21:42.000000000 -0700
+@@ -13,7 +13,7 @@
+ /* ASR fix 02/05/2003: need that regardless of COLOR_OUTPUT to support -jp
+ correctly */
+ #if SFX_LEVEL>=ARJ
+- #define CUSTOM_PRINTF
++/* #define CUSTOM_PRINTF */
+ #define CHUNK_SIZE 512 /* Size of the output block */
+ #define CHUNK_THRESHOLD (CHUNK_SIZE-256) /* Safety bound */
+ #endif
diff --git a/app-arch/arj/files/arj-3.10.22-implicit-declarations.patch b/app-arch/arj/files/arj-3.10.22-implicit-declarations.patch
new file mode 100644
index 000000000000..a23429e7bd99
--- /dev/null
+++ b/app-arch/arj/files/arj-3.10.22-implicit-declarations.patch
@@ -0,0 +1,33 @@
+diff -up arj-3.10.22/environ.c~ arj-3.10.22/environ.c
+--- arj-3.10.22/environ.c~ 2008-03-31 15:19:36.000000000 +0200
++++ arj-3.10.22/environ.c 2008-03-31 15:19:36.000000000 +0200
+@@ -12,6 +12,8 @@
+ #include <conio.h>
+ #include <io.h>
+ #include <process.h>
++#else
++#include <sys/wait.h>
+ #endif
+
+ #include <fcntl.h>
+diff -up arj-3.10.22/arjsfx.c~ arj-3.10.22/arjsfx.c
+--- arj-3.10.22/arjsfx.c~ 2008-03-31 15:17:45.000000000 +0200
++++ arj-3.10.22/arjsfx.c 2008-03-31 15:17:45.000000000 +0200
+@@ -5,6 +5,7 @@
+ *
+ */
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <signal.h>
+
+diff -up arj-3.10.22/arj.c~ arj-3.10.22/arj.c
+--- arj-3.10.22/arj.c~ 2008-03-31 15:17:14.000000000 +0200
++++ arj-3.10.22/arj.c 2008-03-31 15:17:14.000000000 +0200
+@@ -5,6 +5,7 @@
+ *
+ */
+
++#define _GNU_SOURCE
+ #include <stdio.h>
+ #include <signal.h> \ No newline at end of file
diff --git a/app-arch/arj/files/arj-3.10.22-interix.patch b/app-arch/arj/files/arj-3.10.22-interix.patch
new file mode 100644
index 000000000000..8294f1e96bb4
--- /dev/null
+++ b/app-arch/arj/files/arj-3.10.22-interix.patch
@@ -0,0 +1,45 @@
+diff -ru arj-3.10.22.orig/environ.c arj-3.10.22/environ.c
+--- arj-3.10.22.orig/environ.c 2008-03-30 16:51:40 +0200
++++ arj-3.10.22/environ.c 2008-03-30 16:50:16 +0200
+@@ -61,7 +61,7 @@
+ #elif defined(__FreeBSD__)||defined(__NetBSD__)||defined(__APPLE__)
+ #include <sys/param.h>
+ #include <sys/mount.h>
+- #elif defined(__QNXNTO__)
++ #elif defined(__QNXNTO__) || defined(__INTERIX)
+ #include <sys/statvfs.h>
+ #else
+ #include <sys/statfs.h>
+@@ -2286,7 +2286,7 @@
+ else
+ return((LONG_MAX/(spclu*bps)<fclu)?LONG_MAX:spclu*bps*fclu);
+ #elif TARGET==UNIX
+- #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)
++ #if defined(__QNXNTO__)||defined(__sco__)||defined(SUNOS)||defined(__INTERIX)
+ struct statvfs vfs;
+
+ if(statvfs(name, &vfs)==-1)
+@@ -3802,7 +3802,9 @@
+ #elif TARGET==WIN32
+ return(0);
+ #elif TARGET==UNIX
++ #ifndef __INTERIX
+ sync();
++ #endif
+ return(0);
+ #endif
+ }
+diff -ru arj-3.10.22.orig/gnu/configure.in arj-3.10.22/gnu/configure.in
+--- arj-3.10.22.orig/gnu/configure.in 2008-03-30 16:51:40 +0200
++++ arj-3.10.22/gnu/configure.in 2008-03-30 16:41:37 +0200
+@@ -67,8 +67,9 @@
+ DLL_EXT=".dylib"
+ DLL_FLAGS=""
+ ;;
+-interix3*)
++interix*)
+ # not ELF
++ DYN_LIBS="-ldl"
+ DLL_FLAGS="-shared"
+ DLL_CFLAGS=""
+ ;;