summaryrefslogtreecommitdiff
path: root/app-arch/afio/afio-2.5.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-arch/afio/afio-2.5.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-arch/afio/afio-2.5.1.ebuild')
-rw-r--r--app-arch/afio/afio-2.5.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-arch/afio/afio-2.5.1.ebuild b/app-arch/afio/afio-2.5.1.ebuild
new file mode 100644
index 000000000000..45ade45c2dd5
--- /dev/null
+++ b/app-arch/afio/afio-2.5.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Makes cpio-format archives and deals gracefully with input data corruption"
+HOMEPAGE="http://members.chello.nl/k.holtman/afio.html"
+SRC_URI="http://members.chello.nl/k.holtman/${P}.tgz"
+
+LICENSE="Artistic LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/Makefile-r1.patch
+ tc-export CC
+}
+
+src_install() {
+ local i
+ dobin afio
+ dodoc ANNOUNCE-* HISTORY README SCRIPTS
+ for i in 1 2 3 4; do
+ docinto script$i
+ dodoc script$i/*
+ done
+ doman afio.1
+}