summaryrefslogtreecommitdiff
path: root/app-alternatives/yacc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 02:58:11 +0000
commitfbe7acf59ebf6dc3f04a6ef108ff3887fa5d7972 (patch)
tree3669828a2d0c5f7cb1a4bfd79be8032aac558282 /app-alternatives/yacc
parent9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (diff)
gentoo auto-resync : 03:12:2022 - 02:58:11
Diffstat (limited to 'app-alternatives/yacc')
-rw-r--r--app-alternatives/yacc/Manifest3
-rw-r--r--app-alternatives/yacc/metadata.xml23
-rw-r--r--app-alternatives/yacc/yacc-0.ebuild13
-rw-r--r--app-alternatives/yacc/yacc-1.ebuild52
4 files changed, 91 insertions, 0 deletions
diff --git a/app-alternatives/yacc/Manifest b/app-alternatives/yacc/Manifest
new file mode 100644
index 000000000000..b039656ce1e5
--- /dev/null
+++ b/app-alternatives/yacc/Manifest
@@ -0,0 +1,3 @@
+EBUILD yacc-0.ebuild 536 BLAKE2B ccb4b1c59c0452254507b81a52c1d9147a109fdf968ad2e71b5776735e5c59c8aa0447964614941e22d927b995c5ec045bdfa8f890fb5a1874f462ca64459f21 SHA512 aff6ef4ac24044dcec4484395cd4b155617035f8c632fd6550e8a17b1c467e0c164880ca1d0ac9df86f00df09d0879f26063457b85807874361fac822879fe57
+EBUILD yacc-1.ebuild 1319 BLAKE2B 8b2e6c5fd3b6d612f0af1dd61359ac2af8efefeebdf6a321697328310fafb1cff8c6c3871fb366542b123e27ca6b4797b5aa41e1d1f041e659fda5461f72478f SHA512 ecae76ece51d15ac3c531912128c67bbbf31df0cfd089e2899a6c576fc5f8e18f9c8a01752e5130cc6f54a2ab73f65d5cbaa6dd13becfa0c31bddde14c94d4b0
+MISC metadata.xml 604 BLAKE2B a40366e6a7aab1ac9658b2b46cc6409486d2e2b7ac456209b4151974f48facc65e68d2e44965a6eb0680af47663a379da050bfbcf480e6af50951ec6d03647e5 SHA512 24329bbcc9bd0a589559c621a89b0dc26f304f47cdbd62e09bf5d33cb190bdecfc352527970c072080a3c9a7e4a7193b6d7c71ab0a0c83d0dcb76f03e0699a5c
diff --git a/app-alternatives/yacc/metadata.xml b/app-alternatives/yacc/metadata.xml
new file mode 100644
index 000000000000..0672d9fe1a27
--- /dev/null
+++ b/app-alternatives/yacc/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>base-system@gentoo.org</email>
+ <name>Gentoo Base System</name>
+ </maintainer>
+ <maintainer type="person">
+ <email>mgorny@gentoo.org</email>
+ <name>Michał Górny</name>
+ </maintainer>
+ <use>
+ <flag name="bison">
+ Symlink to <pkg>sys-devel/bison</pkg>.
+ </flag>
+ <flag name="byacc">
+ Symlink to <pkg>dev-util/byacc</pkg>.
+ </flag>
+ <flag name="reference">
+ Symlink to <pkg>dev-util/yacc</pkg>.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/app-alternatives/yacc/yacc-0.ebuild b/app-alternatives/yacc/yacc-0.ebuild
new file mode 100644
index 000000000000..40f51b6795ac
--- /dev/null
+++ b/app-alternatives/yacc/yacc-0.ebuild
@@ -0,0 +1,13 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Virtual for yacc (yet another compiler compiler)"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+
+LICENSE="metapackage"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="|| ( sys-devel/bison dev-util/byacc dev-util/yacc )"
diff --git a/app-alternatives/yacc/yacc-1.ebuild b/app-alternatives/yacc/yacc-1.ebuild
new file mode 100644
index 000000000000..d5508b6ebb90
--- /dev/null
+++ b/app-alternatives/yacc/yacc-1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="yacc symlinks"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Base/Alternatives"
+SRC_URI=""
+S=${WORKDIR}
+
+LICENSE="CC0-1.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+bison byacc reference"
+REQUIRED_USE="^^ ( bison byacc reference )"
+
+RDEPEND="
+ bison? ( >=sys-devel/bison-3.8.2-r1 )
+ byacc? ( dev-util/byacc )
+ reference? ( >=dev-util/yacc-1.9.1-r7 )
+ !<dev-util/yacc-1.9.1-r7
+ !<sys-devel/bison-3.8.2-r1
+"
+
+src_install() {
+ if use bison; then
+ # bison installs its own small wrapper script 'yacc-bison'
+ # around bison(1).
+ dosym yacc.bison /usr/bin/yacc
+ newman - yacc.1 <<<".so yacc.bison.1"
+
+ newenvd - 90yacc <<-EOF
+ YACC=bison
+ EOF
+ elif use byacc; then
+ dosym byacc /usr/bin/yacc
+ newman - yacc.1 <<<".so byacc.1"
+
+ newenvd - 90yacc <<-EOF
+ YACC=byacc
+ EOF
+ elif use reference; then
+ dosym yacc-reference /usr/bin/yacc
+ newman - yacc.1 <<<".so yacc-reference.1"
+
+ newenvd - 90yacc <<-EOF
+ YACC=yacc
+ EOF
+ else
+ die "Invalid USE flag combination (broken REQUIRED_USE?)"
+ fi
+}