summaryrefslogtreecommitdiff
path: root/app-admin/yaala
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-03-24 17:44:59 +0000
commit0706fc6986773f4e4d391deff4ad5143c464ea4e (patch)
tree9fd110f9fc996e8a4213eeda994a8c112491b86d /app-admin/yaala
parentaa3411e241a201d53a2689766fe419f2756819f3 (diff)
Revert "gentoo resync : 24.03.2019"
This reverts commit aa3411e241a201d53a2689766fe419f2756819f3.
Diffstat (limited to 'app-admin/yaala')
-rw-r--r--app-admin/yaala/Manifest3
-rw-r--r--app-admin/yaala/metadata.xml3
-rw-r--r--app-admin/yaala/yaala-0.7.3-r1.ebuild70
3 files changed, 75 insertions, 1 deletions
diff --git a/app-admin/yaala/Manifest b/app-admin/yaala/Manifest
index ce711583c960..9498fc6c5bf0 100644
--- a/app-admin/yaala/Manifest
+++ b/app-admin/yaala/Manifest
@@ -1,4 +1,5 @@
AUX yaala-0.7.3-r1-correct-paths.patch 1095 BLAKE2B 5c7a232836bd19ffa678db3c2d522f9d831535e3dc086e014fc45fe233ae9e20aa1a69359ccc2e913b1b2cd66ba29e053957ed32aabdb38948a57e55b485796e SHA512 c44bad33bf23ed089a4ddc2497cc5507c3c1927053c09ed64e39dad95400b0f0d1170da499c504240919262391f6424c5a830298e7c5a49542dd3424fabed8a7
DIST yaala-0.7.3.tar.bz2 41528 BLAKE2B 527f691730cd50f60137bce014958423bea4bf007891ac0a6fa0888099da7678661612369d29b41683de81a25bc92163f0d9f413e5a11e9f86c273e0e866ca8e SHA512 30ad37c2c612f47472a840ea40aa924ffa59828455e7268dc29eb3d0276aab835b54396a29eabce88ef0e357523086b182ca1ec366b50851ecb8d2530f4eac01
+EBUILD yaala-0.7.3-r1.ebuild 1681 BLAKE2B 50fa29f2619f3b16d47d162ad2cd4ff89d035af12f5a58fe326855cff408ff4d2ac79dc1d400ef3dfccffe80ef71c588181655debc9f45cc49c87a13d290475c SHA512 babadaca079b88ab4a0f8c97b7dbacd36f716c3978fb81fdd8da3f0c441ed5bd05e03602d71f9dc4da2e4b7a4bdc2a3d397acd089d869627a9e6f44138841118
EBUILD yaala-0.7.3-r2.ebuild 1623 BLAKE2B 606c3b8b9e69c8b4e4d2887ebcc38ed3523bafd6e87bbe2d7ea52523fd02fecafc0da548dd7a8f0b62fa102e3d6e3d38f5f5cf2b3316fad6290ffbead848658a SHA512 63ccbeedf296fbbea7423dddf5ae04b38855dadb341b8483aae17df9932489fe0b940680c3a43861e8843e296e155817bfc46dd9837fa1317b240a6fd80a7eec
-MISC metadata.xml 238 BLAKE2B fbb26a50a5cd4f4478d909e0aa54bc63c07c072ad947198f61296cd359913b0d7e34fcc3ca64b64db0ac82ed4930d27d7ff934f5134e0a1fc4f2b1eac8c02651 SHA512 af9c2c7ac7e822d72151c5fd3ab45d2f6d88284a6d3e4a845df488c1a2938084ae7baf1fb3d907292d4e672e6c1d6e636a6ea554316bf53e971e2c81a11a3e1b
+MISC metadata.xml 337 BLAKE2B b1435fe71f760cc4fd4b6bceee0d4675b7f7e7b89986544003cfb7bbf59851b02025a8b0839d446efbde8c8240bcbba782d8f88c9e0db59b227de91dc885043a SHA512 a24db5faa68733175428ecdfc9c333e5209cfdbaee9e40a23af29d188068d5400d14d60c7239d890d7e66f640c4a2023cabf9b6d131d2abe58f0e90b221119c6
diff --git a/app-admin/yaala/metadata.xml b/app-admin/yaala/metadata.xml
index 1f0914e3ecd6..893290974a28 100644
--- a/app-admin/yaala/metadata.xml
+++ b/app-admin/yaala/metadata.xml
@@ -5,4 +5,7 @@
<longdescription>
Yet Another Log Analyzer
</longdescription>
+ <use>
+ <flag name="storable">Support for persistence of Perl data structures.</flag>
+ </use>
</pkgmetadata>
diff --git a/app-admin/yaala/yaala-0.7.3-r1.ebuild b/app-admin/yaala/yaala-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..e974cd81bf30
--- /dev/null
+++ b/app-admin/yaala/yaala-0.7.3-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils
+
+DESCRIPTION="Yet Another Log Analyzer"
+HOMEPAGE="http://www.yaala.org/"
+SRC_URI="http://www.${PN}.org/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="gd storable"
+
+RDEPEND="dev-lang/perl
+ gd? ( dev-perl/GDGraph )
+ storable? ( virtual/perl-Storable )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PF}-correct-paths.patch
+
+ sed -i "s:/var/lib/${PN}:/usr/bin:g" packaging/${PN}.cron || die 'Failed to correct path in cron file.'
+}
+
+src_install() {
+ dobin ${PN}
+
+ # Switch to ^y when we switch to EAPI=6.
+ local mod="Y${PN:1}"
+
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/
+ doexe lib/${mod}/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/Data/
+ doexe lib/${mod}/Data/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/Parser/
+ doexe lib/${mod}/Parser/*.pm
+
+ exeinto /usr/lib64/perl5/vendor_perl/${mod}/Report/
+ doexe lib/${mod}/Report/*.pm
+
+ dodoc AUTHORS CHANGELOG README{,.persistency,.selections}
+
+ insinto /usr/share/${PN}
+ doins -r reports
+ doins -r sample_configs
+
+ insinto /etc/${PN}
+ doins {,webserver.}config
+
+ insinto /etc/logrotate.d
+ doins packaging/${PN}.cron
+
+ if use storable ; then
+ dodir /var/lib/${PN}
+ keepdir /var/lib/${PN}
+ chmod 777 /var/lib/${PN}
+ fi
+}
+
+pkg_postinst() {
+ ewarn "It is required that you change the configuration files in /etc/${PN}"
+ ewarn "before you run \`yaala ...\`, otherwise it will refuse to execute because"
+ ewarn "Setup.pm checks whether the variable 'select' has been unquoted and set."
+ echo ""
+ elog "Example configuration files can be found in /usr/share/${PN}."
+}