summaryrefslogtreecommitdiff
path: root/app-admin/xstow/xstow-1.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
commitbed3b604e16fc6075e29f1af8d47507a07035bd3 (patch)
tree1f5d57fd86e90db37f62afb463f4b4c08a2b6eda /app-admin/xstow/xstow-1.1.1.ebuild
parentd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (diff)
gentoo auto-resync : 21:06:2024 - 00:11:18
Diffstat (limited to 'app-admin/xstow/xstow-1.1.1.ebuild')
-rw-r--r--app-admin/xstow/xstow-1.1.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/app-admin/xstow/xstow-1.1.1.ebuild b/app-admin/xstow/xstow-1.1.1.ebuild
new file mode 100644
index 000000000000..d6dcfa3ad50d
--- /dev/null
+++ b/app-admin/xstow/xstow-1.1.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Replacement for GNU stow with extensions"
+HOMEPAGE="https://github.com/majorkingleo/xstow"
+SRC_URI="https://github.com/majorkingleo/${PN}/releases/download/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="ncurses"
+
+DEPEND="ncurses? ( sys-libs/ncurses:= )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ econf $(use_with ncurses curses)
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="${EPREFIX}/usr/share/doc/${PF}/html" install
+ einstalldocs
+
+ # Create new STOWDIR
+ keepdir /var/lib/xstow
+
+ # Install env.d file to add STOWDIR to PATH and LDPATH
+ doenvd "${FILESDIR}"/99xstow
+}
+
+pkg_postinst() {
+ elog "We now recommend that you use /var/lib/xstow as your STOWDIR"
+ elog "instead of /usr/local in order to avoid conflicts with the"
+ elog "symlink from /usr/lib64 -> /usr/lib. See Bug 246264"
+ elog "(regarding app-admin/stow, equally applicable to XStow) for"
+ elog "more details on this change."
+ elog "For your convenience, PATH has been updated to include"
+ elog "/var/lib/bin."
+}