summaryrefslogtreecommitdiff
path: root/app-admin/whowatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/whowatch
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/whowatch')
-rw-r--r--app-admin/whowatch/Manifest7
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-select.patch17
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch19
-rw-r--r--app-admin/whowatch/metadata.xml11
-rw-r--r--app-admin/whowatch/whowatch-1.8.5.ebuild34
-rw-r--r--app-admin/whowatch/whowatch-1.8.6.ebuild35
6 files changed, 123 insertions, 0 deletions
diff --git a/app-admin/whowatch/Manifest b/app-admin/whowatch/Manifest
new file mode 100644
index 000000000000..d76d302454d0
--- /dev/null
+++ b/app-admin/whowatch/Manifest
@@ -0,0 +1,7 @@
+AUX whowatch-1.8.4-select.patch 348 BLAKE2B 7e7b0624e2607e62ef9d00555943e701300fbfbb632e3c800590c97565c3716b705643c49ef261e627570108c4bd1fa8e945826689ab6ff029ccbc4a9c48f88c SHA512 ab2b9aef685c68b913b14d083e95f2b105b8d36e50a40da98f4d35ab173df21a931571d6052b8bb177678561f528175c4a6970c30f8f7aa9a29da2b528cd1e9f
+AUX whowatch-1.8.4-tinfo.patch 627 BLAKE2B 2b7a5623188bda62a038a07ad6796e66821f8e34d53d82605f0ea462171a2145578dc97fa2b374933fac0d710f68c69f90efab52a341510b0e461b67e53e21aa SHA512 7d256fc59184839a1ce6168689763c0b2a1e32c841438979c00ab8c2c2fc0e87e5e8f6002e1433326b94ebf9b917348b2f19b126562e01ab387bfbed79184c7a
+DIST whowatch-1.8.5.tar.gz 133845 BLAKE2B f0f5b80d7adc488030877936ab8d12687f8b5617e445efa604971ae6e0b2de403b6f77a119f9ab1311811900003af85235ad546c425296facece165034b82cad SHA512 9a534dcc859101e3f6636fcfc191be3c0a66b843225dbace0d851f8cca7bbf1374929f604414556c651167c24a223525304fe2963a92b97ba97a8f57179ec738
+DIST whowatch-1.8.6.tar.gz 141801 BLAKE2B d52ae8304d25c570873c65cc3b91d8fe227bf71f1802cc8055332f4614b9ca9f6c17dea10b07bbd20f834623f9e10456b19c6393996f6c66819e7e921ffb6240 SHA512 49aa45b0a88a41c98fb7b548f0f098004c8bcca9ec078e977fcec8bc109c9beab25989003bfff4b3dc38a9d62d69378f64441753a1cca62729d2013d2ed73cb0
+EBUILD whowatch-1.8.5.ebuild 694 BLAKE2B 493fb8d1b96c927eca5059ca1bafa7073f85ec8a5e334dc4341cbdf35cda3e5572128dd03adc2442c08843902f55d75f6e5d985e3fdacf7b0ce8261cb94833ca SHA512 2c3ceebdbbec7055dd7bcea688a3cea207b4545672f05eb8a2996a181b96dd87cdbb6f53cb3b479f1e9a15954bfd2b5d580926ed3bc3b95072d1cb9ec5185a83
+EBUILD whowatch-1.8.6.ebuild 707 BLAKE2B 668d7a1f8c8aa70f3b450732c0d3213089d2edd006e054a2fca89a9cd2d8e652a1f5951351f3ff4b5a33ff7debc3c4d5102f30766d47d72ba375aa0fa3e796eb SHA512 b50c34ee41b33ce227cbb77869c7a8d39da6c8bfeef94746ddfd16247ccf451740cb2131e9ff066894ddd24c0952c7d636285c6c8baa537643643d2048173543
+MISC metadata.xml 388 BLAKE2B d26eb0308267a387313561d328a2663f0345fce18d558e42b3e1b787bdef2e09a352558285621882b1def719b358b98d3314c6f8371049faf152dd565653df6b SHA512 6f9e4b4105915444690434f721d6fcfdc78fff506927a854c13a67d06d81293361f44f19c55fb78e32daa9b70a07410f844924f94a251cbd0aa71adefd9de5f3
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-select.patch b/app-admin/whowatch/files/whowatch-1.8.4-select.patch
new file mode 100644
index 000000000000..0907c70e6750
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-select.patch
@@ -0,0 +1,17 @@
+--- a/src/whowatch.c
++++ b/src/whowatch.c
+@@ -436,12 +436,12 @@
+ gettimeofday(&after, 0);
+ tv.tv_sec -= (after.tv_sec - before.tv_sec);
+ if(retval > 0) {
+- int key = read_key();
++ int key = getkey();
+ key_action(key);
+ }
+ if(tv.tv_sec <= 0) {
+ ticks++;
+- periodic();
++ main_periodic();
+ tv.tv_sec = TIMEOUT;
+ }
+ #endif
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch b/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch
new file mode 100644
index 000000000000..6ad7849ac037
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,14 +16,8 @@
+ dnl Replace `main' with a function in -lkvm:
+ AC_CHECK_LIB(kvm, kvm_openfiles)
+ dnl Replace `main' with a function in -lncurses:
+-CURS=0
+-AC_CHECK_LIB(ncurses, scrollok, [CURS=1 ; LIBS="$LIBS -lncurses"])
+-if test "$CURS" != "1"; then
+- AC_CHECK_LIB(curses, scrollok, [CURS=1 ; LIBS="$LIBS -lcurses"])
+-fi
+-if test "$CURS" != "1"; then
+- AC_MSG_ERROR([Could not find proper curses library])
+-fi
++PKG_CHECK_MODULES(NCURSES, ncurses, [LIBS="$LIBS $NCURSES_LIBS"],
++ AC_MSG_ERROR([Could not find proper curses library]))
+
+ dnl Checks for header files.
+ AC_HEADER_DIRENT
diff --git a/app-admin/whowatch/metadata.xml b/app-admin/whowatch/metadata.xml
new file mode 100644
index 000000000000..740b2bc5107f
--- /dev/null
+++ b/app-admin/whowatch/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>jer@gentoo.org</email>
+ <name>Jeroen Roovers</name>
+ </maintainer>
+ <longdescription>
+ A interactive who program that displays information about the users currently logged into the machine.
+ </longdescription>
+</pkgmetadata>
diff --git a/app-admin/whowatch/whowatch-1.8.5.ebuild b/app-admin/whowatch/whowatch-1.8.5.ebuild
new file mode 100644
index 000000000000..e63c78391d8a
--- /dev/null
+++ b/app-admin/whowatch/whowatch-1.8.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Displays information about users currently logged on in real time"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/"
+SRC_URI="http://wizard.ae.krakow.pl/~mike/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm hppa ~mips ppc x86"
+IUSE=""
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.8.4-tinfo.patch
+ epatch "${FILESDIR}"/${PN}-1.8.4-select.patch
+ eautoreconf
+}
+
+src_install() {
+ dobin src/${PN}
+ doman ${PN}.1
+ dodoc AUTHORS ChangeLog README TODO
+}
diff --git a/app-admin/whowatch/whowatch-1.8.6.ebuild b/app-admin/whowatch/whowatch-1.8.6.ebuild
new file mode 100644
index 000000000000..b29bc3afdbcd
--- /dev/null
+++ b/app-admin/whowatch/whowatch-1.8.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Displays information about users currently logged on in real time"
+HOMEPAGE="http://wizard.ae.krakow.pl/~mike/ https://github.com/mtsuszycki/whowatch/"
+SRC_URI="https://github.com/mtsuszycki/${PN}/releases/download/${P}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.4-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin src/${PN}
+ doman ${PN}.1
+ dodoc AUTHORS ChangeLog README TODO
+}