summaryrefslogtreecommitdiff
path: root/app-admin/whowatch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/whowatch/files
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/whowatch/files')
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-select.patch17
-rw-r--r--app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch19
2 files changed, 36 insertions, 0 deletions
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-select.patch b/app-admin/whowatch/files/whowatch-1.8.4-select.patch
new file mode 100644
index 000000000000..0907c70e6750
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-select.patch
@@ -0,0 +1,17 @@
+--- a/src/whowatch.c
++++ b/src/whowatch.c
+@@ -436,12 +436,12 @@
+ gettimeofday(&after, 0);
+ tv.tv_sec -= (after.tv_sec - before.tv_sec);
+ if(retval > 0) {
+- int key = read_key();
++ int key = getkey();
+ key_action(key);
+ }
+ if(tv.tv_sec <= 0) {
+ ticks++;
+- periodic();
++ main_periodic();
+ tv.tv_sec = TIMEOUT;
+ }
+ #endif
diff --git a/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch b/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch
new file mode 100644
index 000000000000..6ad7849ac037
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.8.4-tinfo.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -16,14 +16,8 @@
+ dnl Replace `main' with a function in -lkvm:
+ AC_CHECK_LIB(kvm, kvm_openfiles)
+ dnl Replace `main' with a function in -lncurses:
+-CURS=0
+-AC_CHECK_LIB(ncurses, scrollok, [CURS=1 ; LIBS="$LIBS -lncurses"])
+-if test "$CURS" != "1"; then
+- AC_CHECK_LIB(curses, scrollok, [CURS=1 ; LIBS="$LIBS -lcurses"])
+-fi
+-if test "$CURS" != "1"; then
+- AC_MSG_ERROR([Could not find proper curses library])
+-fi
++PKG_CHECK_MODULES(NCURSES, ncurses, [LIBS="$LIBS $NCURSES_LIBS"],
++ AC_MSG_ERROR([Could not find proper curses library]))
+
+ dnl Checks for header files.
+ AC_HEADER_DIRENT