summaryrefslogtreecommitdiff
path: root/app-admin/verynice/verynice-1.1-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-admin/verynice/verynice-1.1-r2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-admin/verynice/verynice-1.1-r2.ebuild')
-rw-r--r--app-admin/verynice/verynice-1.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-admin/verynice/verynice-1.1-r2.ebuild b/app-admin/verynice/verynice-1.1-r2.ebuild
new file mode 100644
index 000000000000..e9dc02e399c0
--- /dev/null
+++ b/app-admin/verynice/verynice-1.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit epatch systemd toolchain-funcs
+
+DESCRIPTION="A tool for dynamically adjusting the nice-level of processes"
+HOMEPAGE="https://web.archive.org/web/2010033109/http://thermal.cnde.iastate.edu/~sdh4/verynice/"
+SRC_URI="http://thermal.cnde.iastate.edu/~sdh4/verynice/down/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+S=${WORKDIR}/${PN}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.1-build.patch
+}
+
+src_compile() {
+ tc-export CC
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr
+}
+
+src_install(){
+ emake RPM_BUILD_ROOT="${D}" PREFIX=/usr VERSION=${PVR} install
+ doinitd "${FILESDIR}"/verynice
+ systemd_dounit "${FILESDIR}"/verynice.service
+}